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IMPORTANT!

READ CAREFULLY BEFORE USE.

KEEP FOR FUTURE USE.
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PRIMES - The Company

PRIMES manufactures measuring devices used to analyze laser beams. These devices are employed for 
the diagnostics of high-power lasers ranging from CO2 lasers and solid-state lasers to diode lasers. A wave-
length range from infrared through to near UV is covered, offering a wide variety of measuring devices to 
determine the following beam parameters:

•	 Laser power
•	 Beam dimensions and position of an unfocused beam
•	 Beam dimensions and position of a focused beam
•	 Beam quality factor M²

PRIMES is responsible for both the development, production, and calibration of the measuring devices. This 
guarantees optimum quality, excellent service, and a short reaction time, providing the basis for us to meet all 
of our customers’ requirements quickly and reliably.

PRIMES GmbH
Max-Planck-Str. 2
64319 Pfungstadt
Germany

Tel  +49 6157 9878-0
info@primes.de
www.primes.de
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1	 Basic safety instructions

Intended Use

The MicrsoSpotMonitor MSM has been designed exclusively for measurements carried out in or near the 
optical path of high-power lasers. Please observe and adhere to the specifications and limit values given 
in chapter 19, „Technical data“, on page 114. Other uses are considered to be improper. The information 
contained in this operating manual must be strictly observed to ensure proper use of the device.

Using the device for unspecified use is strictly prohibited by the manufacturer. By usage other than intended 
the device can be damaged or destroyed. This poses an increased health hazard up to fatal injuries. When 
operating the device, it must be ensured that there are no potential hazards to human health.

The device itself does not emit any laser radiation. During the measurement, however, the laser beam is 
guided onto the device which causes reflected radiation (laser class 4). That is why the applying safety regu-
lations are to be observed and necessary protective measures need to be taken.
Observing applicable safety regulations

Observing applicable safety regulations

Please observe valid national and international safety regulations as stipulated in ISO/CEN/TR standards as 
well as in the IEC-60825-1 regulation, in ANSI Z 136 “Laser Safety Standards” and ANSI Z 136.1 “Safe Use 
of Lasers”, published by the American National Standards Institute, and additional publications, such as the 
“Laser Safety Basics”, the “LIA Laser Safety Guide”, the “Guide for the Selection of Laser Eye Protection” 
and the “Laser Safety Bulletin”, published by the Laser Institute of America, as well as the “Guide of Control 
of Laser Hazards” by ACGIH.

Necessary safety measures

DANGER
Serious eye or skin injury due to laser radiation

During the measurement the laser beam is guided on the device, which causes scattered or 
directed reflection of the laser beam (laser class 4). The reflected beam is usually not visible.

X Please take the following precautions.

If people are present within the danger zone of visible or invisible laser radiation, for example near laser 
systems that are only partly covered, open beam guidance systems, or laser processing areas, the following 
safety measures must be implemented: 

•	 Please wear safety goggles adapted to the power, power density, laser wave length and operating 
mode of the laser beam source in use.

•	 Depending on the laser source, it may be necessary to wear suitable protective clothing or protective 
gloves.

•	 Protect yourself from direct laser radiation, scattered radiation, and beams generated from laser radiation 
(by using appropriate shielding walls, for example, or by weakening the radiation to a harmless level).

•	 Use beam guidance or beam absorber elements that do not emit any hazardous substances when they 
come in to contact with laser radiation and that can withstand the beam sufficiently.

•	 Install safety switches and/or emergency safety mechanisms that enable immediate closure of the laser 
shutter.

•	 Ensure that the device is mounted securely to prevent any movement of the device relative to the beam 
axis and thus reduce the risk of scattered radiation. This in the only way to ensure optimum performance 
during the measurement.
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Employing qualified personnel

The device may only be operated by qualified personnel. The qualified personnel must have been instructed 
in the installation and operation of the device and must have a basic understanding of working with high-
power lasers, beam guiding systems and focusing units.

Conversions and modifications

The device must not be modified, neither constructionally nor safety-related, without our explicit permission. 
The device must not be opened e.g. to carry out unauthorized repairs. Modifications of any kind will result in 
the exclusion of our liability for resulting damages.

Liability disclaimer

The manufacturer and the distributor of the measuring devices do not claim liability for damages or injuries 
of any kind resulting from an improper use or handling of the devices or the associated software. Neither the 
manufacturer nor the distributor can be held liable by the buyer or the user for damages to people, material 
or financial losses due to a direct or indirect use of the measuring devices.
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2	 Symbol explanations
The following symbols and signal words indicate possible residual risks:

DANGER
Means that death or serious physical injuries will occur if necessary safety precautions are not 
taken.

WARNING
Means that death or serious physical injuries may occur if necessary safety precautions are not 
taken.

CAUTION
Means that minor physical injury may occur if necessary safety precautions are not taken. 

NOTICE
Means that property damage may occur if necessary safety precautions are not taken. 

The following symbols indicating requirements and possible dangers are used on the device:

Hand injuries warning

Components susceptible to ESD

Read and observe the operating instructions and safety guidelines before startup!

Further symbols that are not safety-related:

Here you can find useful information and helpful tips. 

With the CE designation, the manufacturer guarantees that its product meets the requirements of 
the relevant EC guidelines.

X Call for action
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3	 About this operating manual
This documentation describes how to work with the MicroSpotMonitor MSM and operate it with the LaserDi-
agnosticsSoftware LDS 2.98.
The software description includes a brief introduction on using the device for measurements.

This operating manual describes the software version valid at the time of printing.
Since the user software is continuously being developed further, the supplied data medium may 
have a different version number. Correct functioning of the device is, however, still guaranteed with 
the software.

Should you have any questions, please specify the software version installed on your device. The software 
version can be found under the following menu item: Help > About LaserDiagnosticsSoftware.

Fig. 3.1:	 Information regarding the current software version

4	 Conditions at the installation site
•	 The device must not be operated in a condensing atmosphere.
•	 The ambient air must be free of organic gases.
•	 Protect the device from splashes of water and dust.
•	 Operate the device in closed rooms only.
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5	 Introduction

5.1	 System description

The MicroSpotMonitor MSM determines beam parameters of focused laser beams with medium powers up 
to 200 W in a range between 20 micro meters and one millimeter directly in the processing zone. 
The air-cooled system depicts the laser beam, which is attenuated by different beam splitter and neutral 
density filters, on a CCD sensor. On the basis of the determined beam distribution of a plane, the beam posi-
tion as well as the beam radius can be derived. By means of the integrated z-axis and the measurement at 
different positions of the laser beam the described beam parameters are determined and logged.

The measuring objectives of the MicroSpotMonitor MSM are selected individually, depending on the beam 
source that is supposed to be measured. In this regard, the wavelength (248 up to 1 090 nm) as well as the 
magnification (3.3:1, 5:1, 10:1), which is determined by the focus diameter, are the essential parameters.

The dynamic range of the integrated CCD sensor is amplified to more than 130 dB via an irradiation time 
control, which enables caustic measurements over more than four Rayleigh lengths, as demanded in the 
standard ISO 11146.

Optionally, the MicroSpotMonitor MSM can be equipped with a filter wheel with neutral density filters (OD1 
to OD5). This filter wheel enables the measurement of power densities between several W/cm² up to several 
MW/cm² without having to modify the system. 

Ventilator

Absorber

Access (inspection chamber)
to filter wheel (option) and fixed OD-filter (option)

Cyclone (option)

Knurled screw

Beam entrance

Lever to adjust the 
magnification  

(option)

Transport lock

Traversing motor

Beam path extension (BPE)

Alignment objective (AO)

Standard

Fig. 5.1:	 Components of the MicroSpotMonitor MSM
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5.2	 Measuring principle

The MicroSpotMonitor MSM is a camera-based measuring system. Depending on the application, up to 7 
different optical components can be in the beam path. The purpose and functioning of individual compo-
nents is described in chapter 21.4, „Optical components“, on page 120.

Measuring plane
Upper limit

Mirrors

Trigger

Filter wheel (option)

Lower limit

Measuring  
objective

Beam path extension (BPE)

Absorber

Laser beam

Absorber

Alignment objective (AO)

CCD sensor

Fixed OD-filter (option)

Prisms

Fig. 5.2:	 Optomechanical design
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5.3	 Short overview installation

1.	 Taking safety precautions Chapter 1 on page 9

2.	 Transport

•	 Disassemble the transport lock

Chapter 6 on page 16

3.	 Installation

•	 Make preparations

•	 Set the installation position

•	 Align the device manually

•	 Mount the device firmly

Chapter 7 on page 17

4.	 Connect the water-cooling (500 W version only)

•	 Connection diameter

•	 Observe flow rate

Chapter 8 on page 22

5.	 Electrical connection

•	 Establish voltage supply

Chapter 9 on page 25

6.	 Connect with the PC

•	 Via Ethernet or LAN

Chapter 9.3 on page 27

7.	 Installing the LaserDiagnosticsSoftware LDS on the PC

•	 Software is part of the scope of delivery

•	 Connect the MicroSpotMonitor MSM with the LaserDiagnosticsSoftware LDS

Chapter 11 on page 29

8.	 Measure

•	 Follow the safety instructions

•	 Select and insert the measuring objective

•	 Observe damage thresholds

•	 Perform measurement

Chapter 13 on page 82



16 Revision 02/2019 EN

MicroSpotMonitor MSM

6	 Transport

WARNING
Risk of injury when lifting or dropping the device

Lifting and positioning heavy devices can, for example, stress intervertebral disks and cause 
chronic changes to the lumbar or cervical spine. The device may fall.

X Use a lifting device to lift and position the device.

NOTICE
Damaging/destroying the device

Optical components may be damaged if the device is subjected to hard shocks or is allowed 
to fall. 

X Handle the measuring device carefully when transporting or installing it.

X To avoid contamination, close the measuring objective with the cover provided.

X Only transport the device in the original PRIMES transport box (option). 

6.1	 Disassemble the transport lock

After unpacking the device, the transport lock has to be removed first. The transport lock secures the linear 
actuator of the z-axis. It is located on the bottom plate and is fastened by means of 3 screws (see Fig. 6.1 on 
page 16).

Fig. 6.1:	 Position of the transport lock
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6.2	 Assemble the transport lock

NOTICE
Damaging/destroying the device

The device must only be transported with a mounted transport lock.

X Keep the transport lock for future use.

Before transportation, move the MicroSpotMonitor MSM into the parking position (see chapter 12.5.17, „Po-
sition (menu Presentation > Position)“, on page 77) and mount the transport lock.

7	 Installation

7.1	 Preparation and mounting position

Check the space available before mounting the device, especially the required space for the connection 
cables and the movement range of the z-axis (see chapter 20, „Dimensions“, on page 116). The device 
must be set up so that it is stable and fastened with screw (see chapter 7.3 on page 21).

The MicroSpotMonitor MSM is designed to operate in a horizontal position with a beam incidence from 
above. With an optional side plate (order no. 801-004-060), operation with horizontal beam incidence is also 
possible.

NOTICE
Damaging/destroying the device

Obstacles in the movement range of the MicroSpotMonitor MSM can lead to collisions and 
damage the device.

X Keep the movement range free of obstacles (cutting nozzle, pressure rolls, etc.).
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7.2	 Manually aligning the MicroSpotMonitor MSM

7.2.1	 Important conditions for the position of the focused laser beam

Due to the imaging characteristics of the measuring objective (see chapter 21.4.1, „Measuring objective“, on 
page 121) it is necessary for the laser beam focus to be positioned in a certain range above the measuring 
objective.

NOTICE
Damaging/destroying the device

The focus has to be in a defined range with reference to the measuring objective. In case it 
is too close or too distant, the optics might be damage in case of high beam intensities.

X Use the enclosed alignment tool for the alignment.

The size of the range in which the focus is to be positioned before the first measurement depends on the 
chosen measuring objective, the used wavelength and the type of focusing. The measurement range lies 
within an upper and a lower limit.

Upper limit

If the focus is located too high above the measuring objective, a focus on the image-sided beam path can 
develop. Together with too high beam intensities, the optics might be damaged.

Measuring plane

The beam distribution of the measuring plane is displayed on the CCD sensor.

Lower limit

If the focus is too close to the measuring objective, it can – depending on the type of focusing and the power 
used – damage the entrance lens.

Laser beam

Measuring plane

Measuring plane distance

Measuring objective

Upper limit

Lower limit

Fig. 7.1:	 Measuring range of the MicroSpotMonitor MSM
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7.2.2	 Positioning the focused laser beam above the measuring objective

The measuring plane distance equals the distance of the measuring plane from the upper corner of the mea-
suring objective or the protective glass.
In order to be able to align the MicroSpotMonitor MSM beneath the laser, an associated alignment tool is 
provided with each measuring objective. By means of this alignment tool and a pilot laser beam, you can 
position the device with the necessary accuracy.

1.	 Place the alignment tool directly on the measuring objective (see Fig. 7.2 on page 19) or on the pro-
tective window holder on the measuring objective (see Fig. 7.3 on page 19).

•	 The upper edge of the measuring objective corresponds to the z position of the measuring plane.
•	 When using a protective window with a thickness of 1.5 mm, the measuring plane moves upwards by 

approx. 500 µm.
2.	 Turn on the pilot laser. If the laser hits the marking in the alignment tool vertically, it is displayed centrally 

on the CCD sensor.

Marking in the alignment tool

10x
5x

3.3x

Fig. 7.2:	 Alignment tools for direct placement on the measuring objective

Marking in the alignment tool

10x 5x 3.3x

Fig. 7.3:	 Alignment tools for placement on the protective window holder on the measuring objective
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The measuring plane distance equals the distance of the imaging plane from the upper corner of the mea-
suring objective. It does not only depend on the beam path (standard, beam path extension BPE, alignment 
objective AO) but also on the wavelength (see Tab. 7.1 on page 20).

When using a protective window with a thickness of 1.5 mm, the measuring plane moves upwards 
by approx. 500 µm.

Measuring ob-
jective MOB

NA limit 
values

Typ. magnification Measuring plane distance in mm

Standard BPE AO Standard BPE AO

3.3x
1 064 nm
532 nm
355 nm

1
0.1
0.09

3.12
3.23
3.36

5.65
5.81
6.02

1.12
1.11

*)

73
70.5
67.3

64.6
62.6
60.1

63.7
61.5
57.7

5x
1 064 nm
532 nm
355 nm

0.19
0.18
0.14

4.96
5.15
5.35

8.31
8.6
8.92

1.63
1.59

*)

51.1
49.3
47.2

47.1
45.7
43.8

46.7
45.1
42.7

10x
1 064 nm
532 nm
355 nm

0.24
0.24
0.17

8.84
9.17
9.62

14.39
14.91
15.6

2.77
2.72

*)

29.9
-
-

27.9
-
-

27.6
-
-

Tab. 7.1:	 Measuring plane distances

*) Only suitable for adjustment

Due to the production tolerances, the values of the measuring plane distance contain a deviation of 
± 800 µm. However, it is possible to have the measuring distance of the measuring objective calibrated to 
± 50 µm (TCP calibration).

7.2.3	 Positioning the focused laser beam above the optional cyclone

 For measuring objectives with a cyclone or a protective window special alignment aids are provided.

Cyclone with disassembled protective window 
holder and attached alignment tool

Cyclone with mounted protective window 
holder and removed alignment tool

Marking in the alignment tool

Alignment tool

Fig. 7.4:	 Alignment tool for an optional cyclone using the example of a measuring objective with 3.3x magnification



21 Revision 02/2019 EN

MicroSpotMonitor MSM

7.3	 Install the MicroSpotMonitor MSM

DANGER
Serious eye or skin injury due to laser radiation

If the device is moved from its calibrated position, increased reflected radiation  
(laser class 4) may result during measuring operation.

X When mounting the device, please ensure that it cannot be moved, neither due to an unin-
tended push or a pull on the cables and hoses.

150166.6

20
2

16
0

16
0

21
19

4.
8

54
.8

 ±
0.

5

21

187.5157.5

157.5 187.5
316.6  +12

2x Ø11

4x Ø 6.6 Ø11

2x Ø6.6

Fig. 7.5:	 Fastening bores, view from above

For the installation onto a holder provided by the customer, there are four mounting holes Ø 6,6 mm in the 
bottom plate. We recommend screws M6 of the strength class 8.8 and a tightening torque of 20 N∙m.

 4 Mounting holes Ø 6,6 mm
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8	 Connect cooling circuit (500 W version only)

DANGER
Fire hazard; Damage/Destruction of the device due to overheating

If there is no water cooling or a water flow rate which is insufficient, there is a danger of 
overheating, which can damage the device or set it on fire.

X Operate the device with a connected water cooling and a sufficient water flow rate only.

8.1	 Water quality

NOTICE
Damage/Destruction of the device due to different chemical potentials

The parts of the device which get in contact with cooling water consist of copper, brass or 
stainless steel. Connecting the unit to a colling curcuit containing aluminum components 
may cause corrosion of the aluminum due to the different chemical potentials.

X Do not connect the device on a cooling circuit in which aluminum components are installed.

•	 The device can be operated with tap water as well as demineralized water.
•	 Do not operate the device on a cooling circuit containing additives such as anti-freeze.
•	 Do not operate the device on a cooling circuit in which aluminum components are installed. Especially 

when it comes to the operation with high powers and power densities, it may otherwise lead to corrosion 
in the cooling circuit. In the long term, this reduces the efficiency of  the cooling circuit.

•	 Should the cooling fail, the device can withstand the laser radiation for a few seconds. In this case, 
please check the device as well as the water connections for damages.

•	 Large dirt particles or teflon tape may block internal cooling circuits. Therefore, please thoroughly rinse 
the system before connecting it.

8.2	 Water pressure

Normally, 2 bar primary pressure at the entrance of the absorber are sufficient in case of an unpressurized 
outflow.

NOTICE
Damage/Destruction of the device due to overpressure

X The maximum permissible water inlet pressure must not exceed 4 bar.



23 Revision 02/2019 EN

MicroSpotMonitor MSM

8.3	 Humidity

•	 The device must not be operated in a condensing atmosphere. The humidity has to be considered in 
order to prevent condensates within and outside the device.

•	 The temperature of the cooling water must not be lower than the dew point (see Tab. 8.1 on page 23).

NOTICE
Damage/Destruction of the device due to condensing water

Condensation water inside of the objective will lead to damage.

X Mind the dew-point in Tab. 8.1 on page 23.

Do only cool the device during the measuring operation. We recommend starting the cooling approx. 2 min-
utes before the measurement and terminating it approx. 1 minute after the measurement.
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Tab. 8.1:	 Dew point diagram

Example

Air temperature:		 22 °C
Relative humidity:	 60 %

The cooling water temperature cannot fall below 14 °C.
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8.4	 Water connections and water flow rate

Connection diameter Recommended flow rate Minimum flow rate

PE hoses 12 mm 1.5 l/min (1 l/(min · kW) Not lower than 1.0 l/min

Tab. 8.2:	 Water connections and water flow rate

Remove the sealing plugs of the water connections

1. Push

2. Pull

Release ring
1.	 Please push down the release ring of the connection 

and pull out the plug with your free hand.

2.	 Remove the sealing plugs of the water connections and 
keep it in a save place. 

3.	 Close the flow line (Water In) and the return flow (Water 
Out) of the device, by inserting the hose as far as pos-
sible (approx. 2 cm deep).

Fig. 8.1:	 Remove the sealing plugs of the water connections
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9	 Electrical connection
The MicroSpotMonitor MSM requires a supply voltage of 24 V ±5 % (DC) for the operation. A suitable power 
supply with an adapter is included in the scope of delivery. Please use only the provided connection lines.

Please ensure that all electrical connections have been established and switch the device on before 
starting the LaserDiagnosticsSoftware LDS.
The MicroSpotMonitor MSM serves as a dongle for the software on the PC in order to enable cer-
tain software functions.

9.1	 Connections

Outlet data transfer signal

On/off switch

Input  
external trigger

BNC

Output  
internal trigger

BNC

EthernetRS485 PRIMES bus
D-Sub socket 9 pole

(Power supply connection)

Fig. 9.1:	 Connections
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9.2	 Pin assignment

9.2.1	 Power supply

D-Sub socket, 9-pin (view: connector side)

15

69

Pin Function

1 GND

2 RS485 (+)

3 +24 V

4 Trigger RS485 (+)

5 Not assigned

6 GND

7 RS485 (–)

8 +24 V

9 Trigger RS485 (–)

Tab. 9.1:	 D-Sub socket RS485

9.2.2	 Inlet external trigger

BNC connector (view: connector side)

1

2

Pin Function

1 +5 V (Trigger signal)

2 GND

Fig. 9.2:	 Connection socket inlet for an external trigger in the connection panel

9.2.3	 Outlet internal trigger

BNC connector (view: connector side)

1

2

Pin Function

1 +5 V (Trigger signal)

2 GND

Fig. 9.3:	 Connection socket outlet for the internal trigger in the connection panel

9.2.4	 Outlet internal data-transfer signal

BNC connector (view: connector side)

1

2

Pin Function

1 +5 V (Trigger signal)

2 GND

Fig. 9.4:	 Connection socket outlet for the internal data-transfer signal in the connection panel
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9.3	 Connection to the PC and connect power supply

NOTICE
Damage/Destruction of the device

When the electrical cables are disconnected during operation (when the power supply is ap-
plied), voltage peaks occur which can destroy the communication components of the mea-
suring device.

X Please turn off the PRIMES power supply before disconnecting the cables.

1.	 Connect the device with the PC via a crossover cable or with the network via a patch cable.
2.	 Use the adapter to connect the power supply to the 9-pin D-sub socket (RS485) of the device.

MSM

Adapter

PRIMES Power Supply

Crossover cable

Ethernet

PC LAN

Ethernet

or

Patch cable

Fig. 9.5:	 Connection via Ethernet with a PC or a local network
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10	 Status LEDs
The device has two status LEDs.

Bezeichnung Farbe Bedeutung

Power Green The power supply is switched on

Measuring Yellow A measurement is running

Tab. 10.1:	 Description of the status LEDs on the MicroSpotMonitor MSM

Power supply

Measuring mode

Fig. 10.1:	 Status LEDs on the  MicroSpotMonitor MSM



29 Revision 02/2019 EN

MicroSpotMonitor MSM

11	 Installation and configuration of the LaserDiagnosticsSoftware LDS
In order to operate the measuring device, the PRIMES LaserDiagnosticsSoftware LDS has to be installed on 
the computer. The program can be found on the enclosed medium.
You will find the latest version on the PRIMES website at: https://www.primes.de/en/support/downloads/
software.html.

11.1	 System requirements

Operating system:	 Windows® 7/10
Processor:		  Intel® Pentium® 1 GHz (or comparable processor)
Free disc space:		 15 MB
Monitor:			  19“ screen diagonal is recommended, resolution at least 1024x768
LDS-Version:		  2.98 or higher

11.2	 Installing the software

The installation of the software is menu driven and is effected by means of the enclosed medium. Please 
start the installation by double-clicking the file “Setup LDS v.X.X.exe” (X = placeholder for version number) 
and follow the instructions.

Fig. 11.1:	 Setup of the PRIMES LaserDiagnosticsSoftware LDS

If not stipulated differently, the installation software stores the main program “LaserDiagnosticsSoftware.
exe” in the directory “Programs/PRIMES/LDS”. Moreover, the settings file “laserds.ini” is also copied into this 
directory. In the file “laserds.ini” the setting parameters for the PRIMES measuring devices are stored.
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11.3	 Ethernet configuration

11.3.1	 Enter IP address

The MicroSpotMonitor MSM has a fixed IP address that is specified on the type plate: 
•	 If the MicroSpotMonitor MSM is connected directly to the PC, enter the fixed IP address in the 

menu Communication > Free Communication (see chapter 11.3.2 on page 31).
•	 If the MicroSpotMonitor MSM is connected over a network, the MicroSpotMonitor MSM will 

spend about one minute pulling up a variable IP address in the network.  
You can read off this variable IP address with the provided software, “PrimesFindlp” and enter it 
into the Communication > Free Communication (see chapter 11.3.2 on page 31)

•	 If you want to connect the MicroSpotMonitor MSM to the network using the fixed IP address, 
first turn on the MicroSpotMonitor MSM and then connect the network cable to the MicroSpot-
Monitor MSM. Then enter the fixed IP address in the menu Communication > Free Commu-
nication (see chapter 11.3.2 on page 31).

The standard IP address of the MicroSpotMonitor MSM is:

IP Address: 	 192.168.116.84
Subnet mask: 	 255.255.255.0

The PC must also have an IP address in the same subnet, for example:

IP Address: 	 192.168.116.XXX
Subnet mask: 	 255.255.255.0

The first three blocks of the IP address must match the IP of the  MicroSpotMonitor MSM.

192

255

168

255

116

255

80

0

Type plate MSM

Fig. 11.2:	 Ethernet configuration in the dialogue window Ethernet
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11.3.2	 Establishing a connection to PC (menu Communication > Free Communication)

1.	 Please start the LaserDiagnosticsSoftware LDS (see chapter 12 on page 34).
2.	 Open the dialogue window Communication > Free Communication.
3.	 Choose in the field “Mode” TCP (the option “Second IP” must not be activated!).
4.	 Enter in the field “TCP” the IP Address.
5.	 Click on the Connect button (“connected” appears in the bus monitor).
6.	 Click on the Find Primes Devices button.
7.	 Click on the Safe Config button (the configuration is saved and does not need to be re-entered when 

starting the LaserDiagnosticsSoftware LDS again).

192 168 116 84

Fig. 11.3:	 Establishing a connection in the dialogue window Free Communication
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11.3.3	 Changing the standard IP address of the device (menu Communication > Free Communica-
tion)

If the fixed IP address of the MicroSpotMonitor MSM conflicts with another device bearing the same IP ad-
dress on the network, the fixed IP address of the MicroSpotMonitor MSM can be changed.

NOTICE
Device malfunction due to erroneous entries

While changing the IP address, it is possible that another EE cell might be overwritten by a 
mistype, for example, and the MicroSpotMonitor MSM could thus be rendered unusable. 

X Only very skilled users should attempt to change the IP address.

You can change the preset IP address in the menu Communication > Free communication by means of 
the following commands:

IP-address
(Sample address)

192. 168. 116. 85

   

Commands se0328wxyz se0329xyz se0330xyz se0331xyz

Tab. 11.1:	 Changing the IP address

In this case xyz are place holders of the four IP-address bytes (values 1 - 254) which always have to be 
entered with three digits!
For example, the number 84 has to be entered like this: 084.
For reasons of clarity the symbol  marks a space.
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Example: You will change the IP address from 192.168.116.85 to 192.168.116.86.

1.	 Please start the LaserDiagnosticsSoftware LDS (see chapter 12 on page 34).
2.	 Open the dialogue window Communication > Free Communication.
3.	 Choose in the field “Mode” TCP (the option “Second IP” must not be activated!).
4.	 Enter the current IP address in the “TCP” field.
5.	 Click on the Connect button (“connected” appears in the bus monitor).
6.	 Activate the check box Write bus protocol (the protocol can be helpful in case of problems):
•	 The protocol is stored in the installation index of the LaserDiagnosticsSoftware LDS. 
•	 The file name is buspro.log.YYYY/MM/DD (YYYY/MM/DD = date file was created).
7.	 Enter the following in the field “Command”: se0331086 

(please make sure that the blank character  is entered correctly).
8.	 Click on the Send button and wait for the confirmation in the bus monitor  

(see Fig. 11.4 on page 33 „-> Adr:0331 Wert: 086“)
9.	 Please turn off the device and turn it on again. After the restart the IP-address is updated.

 

Confirmation

se0331 086

Adr: 0331 Wert:086

Fig. 11.4:	 Changing the IP address in the dialogue window Free Communication
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12	 Description of the LaserDiagnosticsSoftware LDS
The LaserDiagnosticsSoftware LDS is the control centre for all PRIMES measuring devices which measures 
the beam distribution as well as focus geometries by means of which the beam propagation characteristics 
can be determined.
The LaserDiagnosticsSoftware LDS includes all functions necessary for the control of measurements and 
displays the measuring results graphically.
Moreover, the systems uses the measured data to carry out an evaluation in order to give the operator of the 
beam diagnosis an information regarding the reliability of the measuring results.

Please do not start the LaserDiagnosticsSoftware LDS before all devices are connected and turned 
on.

Please start the program by double-clicking the LDS symbol  in the new start menu group or the desktop 
link.

12.1	 Graphical user interface

Firstly, a start window is opened in which you can choose, whether you would like to measure or whether 
you would just like to depict an existing measurement (factory setting “measurement”).

Fig. 12.1:	 Start window of the LaserDiagnosticsSoftware LDS

After the detection of the connected device, the graphical user interface and several important dialogue 
windows are opened.

In order to ensure that corresponding information can be assigned quickly, special markups for menu items, 
menu paths and texts of the user interface will be used in the following chapters.

Markup Description

Text Marks menu items.
Example: Dialogue window Sensor parameters

Text1 > Text2 Marks the navigation to certain menu items. 
The Order of the menus is depicted by means of the Sign “>”
Example: Presentation > Caustic

Text Marks buttons, options and fields.
Example: With the button Start

Fig. 12.2:	 Special markups for menu items, menu paths and texts
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The graphical user interface mainly consists of the menu as well as the toolbar by means of which different 
dialogue or display windows can be called up.

Dialogue window

Tool bar

Menu bar

Fig. 12.3:	 The main elements of the user interface

It is possible to open several measuring and dialogue windows simultaneously. In this case, windows that are 
basically important (for the measurement or the communication) remain in the foreground. All other dialog 
windows fade into the background as soon as a new window opens.

Fig. 12.4:	 The main dialogue windows
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12.1.1	 The menu bar

In the menu bar, all main and sub menus offered by the program can be opened.

Fig. 12.5:	 Menu bar
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12.1.2	 The toolbar

By clicking the symbols in the toolbar, the following program menus can be opened.

   1         2        3            4          5        6         7        8           9                                                   10                       11

File administration                   Notation                            File selection                              Plane selection
                                  

Fig. 12.6:	 Symbols in the toolbar

1 - Create a new data record
2 - Open an existing data record
3 - Save the current data record
4 - Open the isometric view of the selected data record
5 - Open the variable contours line view
6 - Open review (86%)
7 - Open false color depiction
8 - Caustic presentation 2D
9 - List with all data records opened
10 - Display of the selected measuring plane
11 - Display of the measuring devices available for the bus by means of graphical symbols

All measuring results are always written into the document selected in the toolbar. 
It is only possible to display documents chosen here. After opening, the data set has to be explicitly selected. 
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12.1.3	 Menu overview

File

New Opens a new file for the measuring data

Open Opens a measuring file with the extensions “.foc” or “.mdf”

Close Closes the file selected in the toolbar

Close all Closes all files opened

Save Saves the current file in foc- or mdf format

Save as Opens the menu for the storage of the files selected in the toolbar. Only files with the 
extensions “.foc” or “.mdf” can be imported safely

Export Exports all current data in protocol format “.xls” and “.pkl”

Load measurement pref-
erences

Opens a file with measurement settings with the extension “.ptx”

Save measurement pref-
erences 

Opens the menu to save the settings of the last program run. Only files with the exten-
sion “.ptx” can be opened

Protocol Starts a protocol of the numeric results. They can either be written into a file or a data 
base

Print Opens the standard print menu

Print preview Shows the content of the printing order

Recently opened files Shows the file opened before

Exit Terminates the program

Edit

Copy Copies the current window to the clipboard

Clear plane Deletes the data of the plane selected in the toolbar

Clear all planes Deletes all data of the file selected in the toolbar

Change user level By entering a password a different user level can be activated.

Measurement

Environment Different system parameters can be entered, e.g.:
- Reference value for the laser power
- Focal length
- Wavelength
- Comment
- Device offset (Not relevant for MicrosSpotMonitor MSM)

Sensor parameters The following device parameters can be e.g. set here:
- The mechanical locked area of the z-axis
- The spatial resolution (32, 64, 128 or 256 Pixel)
- The manual settings of the z-axis
- Choosing the measuring devices connected to the bus
- Deactivating the z-axis

Beamfind settings Not relevant for MicrosSpotMonitor MSM

CCD info Provides information on device parameters

CCD settings Special settings can be made, e.g.:
- Trigger mode
- Trigger level
- Exposure time
- Wave length
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LQM-Adjustment Not relevant for MicrosSpotMonitor MSM

Power measurement Not relevant for MicrosSpotMonitor MSM

Single This menu item enables the start of single measurements, of the monitor mode and the 
video mode

Caustic Enables the start of a caustic measurement. Not only automatic measurements but also 
serial measurements of manually set parameters are possible. The automatic measure-
ment starts with a beam search and then caries out the entire measuring procedure 
independently. Only the z-range that is to be examined as well as the desired measuring 
plane have to entered

Start adjustment mode Not relevant for MicrosSpotMonitor MSM

Options Enables the setting of device parameters

Presentation

False colors False color display of the spatial power density distribution

False colors (filtered) Usage of a spatial filtration (spline function) on the false color display of the power den-
sity distribution

Isometry 3-dimensional display of the spatial power density distribution

Isometry 3D Allows a 3D display of caustic and power density distribution with spatial rotation as well 
as an optional isophote display

Review (86%) Numerical overview of measuring results in the different layers basing on the 86% beam 
radius definition

Review (2. moment) Numerical overview of the measuring results in the different layers basing on the 2. mo-
ment beam radius definition

Caustic Results of the caustic measurement and the results of the caustic fit – such as beam 
quality factor M², focus position and focus radius

Raw beam Not relevant for MicrosSpotMonitor MSM

Symmetry check Analysis tool to check the beam symmetry especially for the alignment of laser resona-
tors. No standard feature of the device

Fixed contour lines Display of the spatial laser density distribution with fixed intersection lines for 6 different 
power levels

Variable contour lines Display of the spatial power density distribution with freely selectable intersection lines

Graphical review Enables a selection of graphical displays – among them the radius, the x- and y- position 
above the z-position and the time

System state Not relevant for MicrosSpotMonitor MSM

Evaluation parameter Loading stored evaluation parameters

Color tables Different color charts are available in order to analyse e.g. diffraction phenomena in detail

Toolbar In order to display or to hide the toolbar

Position Moving the device into a defined position

Evaluation Comparison of the measured values with defined limit values and evaluation (optionally)

Communication

Rescan bus The system searches the bus for the different device addresses. This is necessary 
whenever the device configuration at the PRIMES bus was changed after starting the 
software.

Free Communication Display of the communication on the PRIMES bus

Scan device list Lists the device addresses of the single PRIMES devices
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Script

Editor Opens the script generator, a tool, by means of which complex measuring procedures 
are controlled automatically (with a script language developed by PRIMES).

List Shows a list of the opened windows

Python Opens the script generator in order to control complex measuring procedures automati-
cally (scripting language Python)

Help

Activation Enables the activation of special functions

About LaserDiagnostics-
Software LDS

Provides information regarding the software version

Tab. 12.1:	 Menü overview
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12.2	 File

This menu includes – among others – the administration of measurement and setting data.

12.2.1	 New (menu File > New)

By means of New a new file is created.

12.2.2	 Open (menu File > Open)

By means of Open a selected file is opened.

12.2.3	 Close/Close all (menu File > Close/Close all)

Close will close the file that is currently open. Close all will close all files currently open.

12.2.4	 Save (menu File > Save)

The file currently opened is stored. The standard type of file is a binary file format with a minimal memory 
requirements. The file ending for a measuring file of this type is “.foc”. As an alternative, it is possible to store 
the data in a ASCII format with the extension “.mdf”. Information regarding the file format “.mdf” can be 
found enclosed. Only files with this formats can be opened by the program (see also chapter 21.3 on page 
119).

12.2.5	 Save as (menu File > Save As)

You have to assign a file name, choose the storage location and the file format.

Only save the measurement data with the extensions “.foc” or “.mdf”. You can only view measure-
ment data if the respective file was explicitly selected in the toolbar.

12.2.6	 Export (menu File > Export)

Exports the pixel information of the power density distribution to a Excel table (*.xls). As an alternative, the 
numeric results from a “.foc” file can be stored in a tab-separated text file (*.pkl) which can be imported into 
Microsoft Excel. The pkl export function has a coordinate origin in the middle of the measuring area (yellow 
dot).

Measurement Range

Laser Beam

x

Zero Point pkl-coordinates

y

Measring 
Window

Fig. 12.7:	 Coordinates of the pkl-export function (the illustration is not to scale)
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12.2.7	 Load measurement preferences (menu File > Load measurement preferences)

Stored settings can be resorted to with Load measurement preferences. The standardized extension for a 
setting file of the MicroSpotMonitor MSM is “.ptx”.

12.2.8	 Save measurement preferences (menu File > Save measurement preferences)

The current measurement settings are stored (.ptx-file).

12.2.9	 Protocol (menu File > Protocol)

The calculated measurement results from a single plane can directly be written into a text file.
The following is stored:

•	 Date and time of the measurement
•	 Beam position and beam radius (according to 86 %- and 2. moment method definition)

Therefore please activate the check box Write. Then you can directly enter the name in the field Filename or 
you can use the standard selection menu with the button Browse.

Fig. 12.8:	 Window Protocol

12.2.10	 Print (menu File > Print)

You can print directly from the program. The current window can be printed with the menu point Print in the 
menu File. With the menu point Settings it is also possible to change the settings as far as the formats etc. 
are concerned.

12.2.11	 Print preview (menu File > Print preview)

Shows a preview of your printing order.

12.2.12	 Recently opened files (menu File > Recently opened Files)

Selection of the files processed before.

12.2.13	 Exit (menu File > Exit)

Terminates the program.
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12.3	 Edit

12.3.1	 Copy (menu Edit > Copy)

By means of the copy function a direct export of graphics to other programs is possible. In this case the 
content of the current window is transmitted to the Windows clipboard.

12.3.2	 Clear plane (menu Edit > Clear plane)

The content of the actual displayed measurement plane of the measurement data set selected in the toolbar 
is deleted.

12.3.3	 Clear all planes (menu Edit > Clear all planes)

The content of all measurement planes of the measurement data set selected in the toolbar is deleted.

12.3.4	 Change user level (menu Edit > Change User Level)

By entering a password a different user level can be activated.
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12.4	 Measurement

12.4.1	 Measuring environment (menu Measurement > Environment)

Fig. 12.9:	 Dialogue window Measuring Environment

In the dialogue window Measuring Environment data such as the laser type, focal length etc. can be 
stored. These data can be read via Presentation > Review.

Focal length

Stating the focal length is relevant for the evaluation of the caustic measurements. From the caustic process 
and the entered focal length the raw beam diameter on the focussing optic can be calculated.

Wave length

The wave-length is the basis for a correct determination of the beam quality factor M². There are the follow-
ing options:

•	 1.064 μm for Nd:YAG laser
•	 0.532 μm for Green laser
•	 0.355 μm for UV laser

A wavelength can also be typed in numerically.

While only the calibration points of the measuring objective can be configured in the CCD Settingdialog win-
dow, the exact value of the laser’s wavelength can be entered in this window. This value is used in all numeric 
evaluations, such as the calculation of the beam quality factor M². 

Caution: If the wavelength is newly selected in the CCD Setting dialog window, the value in this 
window will be overwritten with the selected calibration point.
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Application

By means of the button Apply the entries can also be changed after a measurement. With the button
Apply all planes the entered values are inserted and settled, while the button Apply only refers to the value 
in the current plane.

Laser power

Entering the laser power is a reference value for the relative power position in the menu point Single mea-
surement or Caustic measurement. Furthermore, a z-axes offset as well as a coordinate rotation angle can 
be entered. 

Comment

Please do not use the character # in the comment field “Comment”. This character is used as a separator 
in the software. If it is entered in the field “Comment”, problems could occur when it comes to storing or 
activating measuring data. 
A line break can be enforced by means of the key combination: <Ctrl> + <Enter>.

12.4.2	 Sensor parameters (menu Measurement > Sensor parameter)

Adaptable squares

Z

Y

Fig. 12.10:	 Dialogue window Sensor parameters

Mechanical limits

By pulling the turquoise square with the mouse pointer you can restrict the movement range of the y- and z-
axis. Therewith you can prevent damages in case other components reach into the movement range of your 
device. The maximum value corresponds to the value Y3 and Z3.

Device

By means of this option, you can select the device which is supposed to be operated. Depending on the 
number of devices connected, additional device numbers are assigned.

RPM

Not relevant for MicrosSpotMonitor MSM.
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Resolution

Here you can enter the number of pixels in the measuring window, ranging from 32 x 32 to 256 x 256 pixels.
Generally, 64 pixels per line and a total of 64 lines is sufficient. Please keep in mind that the more pixels there 
are, the longer the measurement will take.	

Detector

Not relevant for MicrosSpotMonitor MSM.

Manual z-axis

With this function you can deactivate the z-axes of the measuring system. This is useful if you want to use 
external movement axes. In this case you can manually assign a z-value to every measurement plane in the 
dialogue window Single measurement.

12.4.3	 Beam find settings (menu Measurement > BeamFind Settings: Beamfind 

Not relevant for MicrosSpotMonitor MSM.
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12.4.4	 CCD info (menu Measurement > CCD Info)

The most important device data is shown in the menu Measurement > CCD Device Info. Here you can see 
the magnification information for the measuring objective and also check which beam path is turned on.
If obvious default values (1:1) are shown instead of the actual magnification, then please check the mounting 
of the measurement objective. 

Fig. 12.11:	 Window CCD Info
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12.4.5	 CCD settings (menu Measurement > CCD Settings)

Fig. 12.12:	 Dialogue window CCD Settings

The wavelength, attenuation, and operating mode are all set in the CCD Settings dialog window.

Trigger modes

The appropriate settings must be configured here in keeping with the operating mode of the laser to be mea-
sured. Here it is important to consider that pulsed lasers with a pulse frequency of more than 500 Hz can be 
measured in cw mode. If, however, the operating mode is set to pulsed and a cw laser system is involved, 
the measuring device will always display the error message “Error Black Pixel Measurement” or “Time Out 
During Measurement” in reaction to a measurement request.

Delay

This function can only be used with a “triggered operation” trigger mode. The time the measuring system 
should wait between when it detects the trigger pulse and the start of the measurement is set here. Together 
with the function “Integration Duration”, defined “Windows” from the plus cycles can be measured (e.g. ex-
actly one pulse or parts of an ms pulse. The minimum delay is 12 µs.

CCD operating modes

Three different modes can be set here. If the Raw Data setting is activated, the measuring system will return 
the uncompensated data of the CCD when a measurement is requested. Especially with NIR irradiation, 
these can be riddled with measuring errors such as “smear effect” readout noise. Even the numeric beam 
data generated generated from this data will be affected by this. 
If a Background is selected as the operating mode, only correction data will be returned while measuring. 
Measuring Data mode should always be the default setting here though. Only when this mode is turned on 
can the measuring system deliver reliable measuring values.



49 Revision 02/2019 EN

MicroSpotMonitor MSM

Integration duration

This function sets a defined integration duration. The optimizer must be deactivated before this can be ac-
complished, since otherwise the measuring device itself will optimize and thus change the integration dura-
tion. This function is also used mainly in measuring pulsed laser systems.

Filter wheel

Which filter is needed for measuring depends on the wavelength and the intensity of the laser beam being 
measured and the appropriate one must be chosen specifically for each measuring task. 
A filter can be considered suitable when all measuring planes of a caustic measurement can be measured 
using an exposure time between 18 ms (-20 dB) and 0.18 ms (-60 dB). Outside of these limits, the S/N ratio 
of the CCD declines, thus reducing the accuracy.

Wavelength

Due to the wavelength-dependent overall magnification of the camera-based measuring system, it is impor-
tant to check that the right selections have been made before each measurement. The wavelengths shown 
here represent the calibration points of the measuring objective. As a result of the achromatic properties of 
the measuring objective, a wavelength range between 1 030 and 1 100 can be achieved, for example, with a 
calibration point at 1 064 nm without causing generating measuring errors.

Trigger

The trigger menu is only pertinent when measuring pulsed laser systems. A fixed value (2 001) is generally 
specified for the trigger diode by default. This value describes the threshold value at which a trigger signal 
is emitted. If you switch the trigger to automatic, the trigger level will first be set to the maximum value. The 
Test button is renamed in Optimize. In the optimize routine (laser must be turned on), the trigger threshold 
is lowered gradually until the MicroSpotMonitor starts receiving trigger signals (lower trigger level). The trigger 
level is then increased until the MicroSpotMonitor stops receiving trigger signals (top trigger level). The final 
trigger level is determined by calculating the arithmetic mean of the two limit values. External trigger entry 
can be activated via the menu point Trigger Channel. Transfer signal pertains to the transfer output of the 
MicroSpotMonitor. Here it is possible to define the CCD sensor state at which there should be a trigger signal 
(e.g. for turning on the laser).

Input  
external trigger

BNC

Ausgang  
Interer Trigger

BNC

Fig. 12.13:	 Trigger connections
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12.4.6	 LQM adjustment (menu Measurement > LQM Adjustment)

Not relevant for MicrosSpotMonitor MSM.

12.4.7	 Power measurement (menu Measurement > Power Measurement)

Not relevant for MicrosSpotMonitor MSM.

12.4.8	 Single (menu Measurement > Single)

21
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Fig. 12.14:	 Dialogue window Measurement settings
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1 Single
Monitor
Video Mode

Starts a measurement in the chosen plane
Starts repeated measurements in the chosen plane automatically

2 Start Starts a measurement in the currently chosen plane

3 Stop Finishes the measurement in the currently chosen plane

4 Reset The measuring device is reset

5 Stop Motor Not relevant for MicrosSpotMonitor MSM

6 Plane Selection of the measuring plane (0-49) either explicit or by means of the buttons (+/-)

7 Entry field Numerical entry of the z-position

8 Copy Copies all settings (window size and window position; x, y, z; etc.) from the former plane 
to the current plane (e.g. 1>>2)

9 Find beam Starts an automatic beam search in the current measuring plane

10 Scan Starts an automatic beam search with the MicrosSpotMonitor MSM. The algorithm 
works at a fixed z-position and searches only within the range of the specified measuring 
window.

11 Ampl. Slide control in order to adjust the optical amplification (exposure time of the CCD)

12 Power Slide control in order to adjust the laser power to save it in the software

13 Entry field Power Numerical input of the laser power to save it in the software

14 Entry field Ampl. Numerical input of the electrical amplification

15 Averaging Analysis of the serial measurements. Averaging algorithms: average value, values of the 
maximum pixels and the value of the maximum trace

16 Averaging Selectable number (1 – 50) of single measurements for the averaging

17 LED symbol and 
bar graph display

Display for the degree of the signal saturation (LED green ≙ ok, red ≙ not ok)

18 False color Activates the option of the false color presentation

19 Zoom Magnification settings for the measuring window

20 Symmetric This option enforces the usage of square measurement windows, whose size is only 
adjustable via x.

21 X/Y Set the measurement window size for non-square windows

22 Display Measuring window shows the current measuring result

23 Z Slide control in order to set the z-position

Tab. 12.2:	 Explanation of input and setting elements
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With the dialogue window Measurement settings either single measurements or repeated measurements 
can be carried out. The measuring window position can be set either manually or automatically.

Controlling measuring modes (individual measurement, monitor, and video mode)

There is a total of three different measuring modes that can be selected here. In the Individual Measure-
ment and Monitor measuring mode, all necessary compensations (smear effect, diffusion) and exposure 
time adjustments are performed every time a new measurement is carried out. Valid measuring data is gen-
erated in this mode.

The measuring mode VideoMode does not produce valid measurement data. Here the exposure time is 
carried over from the last measurement and does not vary. Compensation measurements are not performed, 
making it unnecessary to consider or compensate for measuring artifacts such as smear effects.
Due to the “high” measuring frequency of about 5 Hz, this operating mode is particularly suited for use when 
aligning the device. The numeric results should not be interpreted absolutely, but rather always relative to 
each other.

Power

The slider sets the actual laser power, so the software algorithm can calculate the spacial power density. It 
can be set to any power up to the maximum. 
The maximum power is entered in the menu under Measurement > Environment. The power density is 
calculated in relation to the power values set here. Up to 50 individual measurements can be recorded in a 
measurement file. The results can be easily compared and analyzed with the various presentation functions 
of the LaserDiagnosticsSoftware LDS.

Optical amplification (opt. ampl.)

This function activates the automatic adjustment of the exposure time of the CCD for every measurement. 
The function must be activated in order to keep the signal/noise ratio consistently high for a caustic measure-
ment. 
For special measuring applications, however, it might make sense to deactivate this function and set the ex-
posure time to a fixed value between 12 µs and 200 ms. Here it is important to ensure sufficient attenuation 
of the laser beam with the help of the fixed ND filter or the filter wheel.

Copy

Using the Copy button, you can apply the measurement settings for window size, window position, power, 
and amplification from the previous measuring plane.

Beam search

The Beam Search will initiate an automatic beam search. When this happens, the system will only search 
the area of the currently set window for the set z position.
If the beam search is completed successfully, a measuring window with the appropriate size and position 
will appear on the display screen. The beam can then be accepted using the Start button. The size of the 
measuring window depends on the magnification of the measuring objective. The measuring objective and 
the wavelength are the influencing variables here.

Scan

For devices such as the LaserQualityMonitor LQM, the measuring window is much smaller than the measur-
ing area defined with the x- and y-axis (2 mm x 2 mm). The beam search is therefore supplemented with the 
Scan command. Once a scan is initiated, the MicroSpotMonitor MSM will automatically sense the measuring 
area. If a point of maximum intensity can be identified, the MicroSpotMonitor MSM will automatically zoom in 
on this area and adjust the measuring window size accordingly.

Size of the measuring window

During a manual beam search, you can define the location and size of the measuring window yourself in 
the dropdown menu within the mechanical limits. You can change the location of the measuring window by 
clicking on it and dragging the frame with the mouse. 
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Z-Slider

The location of the window in the z direction (height) can be set by the z-slider or entering a numeric value.

Symmetrical

Once this function is activated, only rectangular measuring windows will be allowed. In cases where an ellipti-
cal or even a square laser beam is being measured, this function should be deactivated so that the measur-
ing window can be optimally adjusted.

False color rendering

False color rendering is activated by clicking on the corresponding button. A measurement is initiated by 
clicking on the Start button. Selecting Monitor and pressing the Start button will initiate an ongoing, repeat-
ing measurement with the current settings. The repeat rate depends on the spacial resolution and the type of 
communication between the PC and the MicroSpotMonitor MSM.

Zoom function

The zoom function allows for detailed magnification of the measuring area.
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12.4.9	 Caustic measurement (menu Measurement > Caustic)

The caustic measurement is a serial measurement where the z position is varied. The results are stored in 
different planes. A different z-position is assigned to every measuring plane. As the beam radius as well as 
the power density change in every z position, the position as well as the size of the window and the signal 
strength can vary from plane to plane. The parameters are automatically adjusted in the process and can 
also be configured separately for each measuring plane.

Parameters (start number of the plane)

Under Start, the start number at which the measurement is initiated can be entered for the plane. By default, 
the start number is generally set to zero and should only be changed when you are measuring in an existing 
document and don’t want the existing measurement data to be overwritten. If, for example, you have mea-
sured a caustic with 21 planes and want to magnify the measuring area to the smaller z-values, you can set 
the start plane to 21 and modify the measuring area appropriately. The new measuring values will then be 
written into the existing document starting with plane 21.

In the Quantity selection field, the number of planes to be measured in the specified z range is set. The fol-
lowing should be considered here:

•	 Since the LaserDiagnosticsSoftware LDS always sets the measuring plane distances so they are equi-
distant (equal spacing) and the measuring area is almost always situated symmetrically around the focal 
point, an odd number of measuring planes should be selected. This ensures that the focus plane is 
measured. 

•	 Beam measurement norm DIN 11146 specifies that at least 10 measuring planes should be measured. 
Furthermore, five measurements should also be taken within a Rayleigh length and the other beyond 5 
Rayleigh lengths. In order to meet all of the requirements with equidistant distribution, at least 17 mea-
suring planes must be measured in a range of ± 3 Rayleigh lengths. 

Mode (automatic and manual settings)

There are two different measuring modes for caustic measurement. In “Automatic” mode, the measuring 
system and the LDS determine the ideal measuring window position (x- and y-direction) for each measuring 
plane and the optimal measuring window size for the fill factor. Furthermore, the plane location in the z-direc-
tion is also calculated based on the specifications (number of measuring planes, measuring limits z-direction).

Especially when adjusting the measuring window size and the measuring window position in the x- 
and y-direction, the number of iterations (max. three per plane) can result in an extended measure-
ment duration.

It is therefore possible to change the measuring mode to “Manual Settings” for recurring measuring tasks 
and for repeating measurements. In this case, the measuring system will take the measuring window posi-
tions and measuring window sizes from the previous measurement or from a .ptx file. This reduces the mea-
surement duration considerably, but does require that the location and parameters of the laser beam change 
only minimally.

Beam search

This selection field specifies which plane the caustic measurement should be started in. If the optional Beam 
Find function is activated in the Options dialog window, that is also the plane in which this function will be 
performed. When the Beam Find function is deactivated, this plane must be manually measured ahead of 
time to make sure that the laser beam is found.

The window can be adjusted under the Adjust menu point. The settings for spacial resolution of the beam 
search, the threshold value, and the minimum signal strength can be entered under the Details menu point. 
Beam search can be turned off in the Measurement > Option (only for advanced users) menu by deacti-
vating the checkbox Enable Beam Find Process.
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Automatic caustic measurement (menu Measurement > Caustic > Automatic)

Fig. 12.15:	 Dialogue window Caustic settings

During automatic caustic measurement, the minimum and maximum z-position is selected together with the 
number of measuring planes. The measurement cycle begins with an automatic beam search in the specified 
starting plane. The beam search only occurs within the area of the starting plane’s measurement window. 

Settings can be entered manually. After manually entering the settings for the measurement planes as de-
scribed in the following section, the caustic measurement can be repeated automatically by choosing the 
Manually adjusted mode.

It is also possible to store measurement settings such as window size, position, etc. in a data file to be re-
loaded again if necessary (File > Safe/Load measurement preferences).

A measurement cycle is started by pressing the Measure button. All planes will be measured then one after 
the other during the measurement cycle.

Manual caustic measurement as time series (menu Measurement > Caustic > Manually adjusted)

The manual caustic measurement consists of a series of individual measurements at various z-positions, with 
the results being stored in their own planes.

12.4.10	 Start adjust mode (menu Measurement > Start Adjust mode)

Not relevant for MicrosSpotMonitor MSM.



56 Revision 02/2019 EN

MicroSpotMonitor MSM

12.4.11	 Option (advanced user only) (menu Measurement > Option)

Fig. 12.16:	 Dialog window Option

Enable beam find process

The Beam Find function must be used for caustic measurement. This involves an algorithm that separates 
the measuring signal from the measurement artifacts (e.g. noise) via an adjustable trigger threshold and 
adapts the size of the measuring window to this signal. This algorithm is only executed in the beam search 
plane (Dialog window Caustic). On all other measuring planes, the measuring window size is determined us-
ing the fill factor. 
If this function is deactivated, the beam search plane must be manually “premeasured” in the measuring 
system. Otherwise the measuring system might end up positioning the measuring window on the edge of the 
measuring area where there is no measuring signal. This makes it impossible to take a meaningful measure-
ment. 
If you turn the Beam Find function off and have the measuring measure the beam search plane system be-
fore each caustic measurement, you can save about 20 sec of measuring time per caustic measurement.

Summary: This function should be activated by default and only deactivated by experienced users. Turning 
off this function can shorten the time for caustic measurements by about 15 %.

Fillfactor

The fill factor is the quotient of the beam diameter and the length of the sides of the measuring window. As 
long as the measuring signal is not cut off and there are no noise components in the measuring result and 
now errors in the offset determination, the fill factor won’t influence the accuracy at all. But since every real 
measuring signal is tainted with noise and since the precision with which the zero level of a measuring signal 
can be determined is finite, very small fill factors can lead to a high level of accuracy. Depending on how 
substantial the RMS noise is and the errors in the zero level determination of a measuring plane, the optimal 
fill factor value to produce the best possible mathematical result will be different. 



57 Revision 02/2019 EN

MicroSpotMonitor MSM

For TopHat and Gaussian beam shaped laser beams, the fill factor should range between 0.5 and 0.7. If the 
beam has diffraction rings, however, and if these are located completely within the measuring window, the 
optimal value for the fill factor can be between 0.5 and 0.6.

By default, the value should be set to: “Max 0.7 Min 0.5 Target 0.6”. For extremely deformed beams, the 
value may be changed to “Max 0.6 Min 0.4 Target 0.5”.

Font size

The font size for the most important display window can be changed here.
It is set to 10 points at the factory.

Open windows

When the window opening function is activated, some basic windows are opened when the LDS is started. If 
you don’t want this to happen, the function can be deactivated.
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12.5	 Presentation

This chapter describes the presentation, analysis and storage of measuring results.

In order to carry out comparisons between different measurements, the program can manage several 
measuring data sets simultaneously. The opened data sets are shown in the toolbar. In order to open one 
presentation, the data which is to be examined is selected in the list of the data selection and afterwards the 
desired kind of presentation is chosen.

File management functions as well as various display types can be pulled up directly with the symbols in the 
menu bar.

Fig. 12.17:	 Selection of a data set

On the selection plane, it is possible to switch back and forth between different image storages of the mea-
suring series. When plane selection is activated, it is possible to move up or down by clicking the cursor. 
When plane selection is set to Global in the display menu, then it is also possible to move up/down with the 
cursor button. 

In the menus for the notation of single measurements (Presentation > Variable contour lines, Presentation 
> Isometry and Presentation > False color presentation) the option Autoscale effects the usage of the 
entire display range for the measuring values.

Moreover, you have the possibility of switching between different image memories of series of measurements 
by means of the Plane selection. Switching is also possible by means of the cursor keys up/down if the 
plane selection is selected. If the plane selection in the display menus is set on Global, switching simultane-
ously between the planes is possible via the selection in the toolbar.
The title of the dialogue window indicates the name of the data sets shown.

For the parallel evaluation of several measurements the program has 50 image memories which can record 
one measurement each. These image memories (measuring plane) can also be used in order to record 
changed measurement values in case of a parameter variation. 

Due to the variation of the z-position in the different planes a caustic measurement is realized. Due to a 
change of the laser power it is possible to simulate, e.g. the thermal inflow-behavior of the system. Similarly, 
time series are possible. Respective displays are, for instance, possible by means of the menu item Presen-
tation > Graphical review.
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12.5.1	 False colors (menu Presentation > False colors)

Here, a false color presentation of the measured power density distribution is generated.

Fig. 12.18:	 Dialogue window False colors

The used color scale is shown on the left. For a higher sensitivity, e.g. for the analysis of diffraction figures, it 
is possible to switch the used color scale in the menu Presentation > Color Tables. By means of the slide 
control on the left hand side of the color scale you can display the sections of different ADC values with the 
corresponding radii.

Apart from the automatic scaling, there are three more types of scaling:

Scale on density

All planes of a caustic measurement are scaled on the maximum measured power density. This is supposed 
to help comparing the different planes more easily.

Pixel scale

This scaling is only interesting when it comes to the usage of asymmetric measuring windows. In this case 
the axis of the windows are no longer a function of the measuring window size but of the number of pixels 
measured.

Window scale

With regard to this function, all measuring windows of a caustic measurement are enlarged to the size of 
the maximum measuring window. This function, too, is supposed to help comparing the different measuring 
planes of a caustic measurement more easily. 
The beam axes can be displayed in all types of scaling by activatng the check box Beam axis.

Rule function

The beam can be measured in any direction by left-clicking on the image.
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12.5.2	 False colors (filtered) (menu Presentation > False colors (filtered))

The special function of the filter is called spline – function. It is characterized by the fact that the position of 
the maximum is maintained. The single pixels in the matrix are weighed by means of a 1-2-1 filter in order to 
reduce the noise. 
This filter can also be used multiple times without the position of the maxima being moved.

Fig. 12.19:	 Dialogue window False colors (filtered)

12.5.3	 Isometry (menu Presentation > Isometry)

This menu item generates a spatial display of the measured power density distribution of a plane. The false 
color display can be deactivated. A turn of the distribution by 90°, 180° and 270° each is possible.

Fig. 12.20:	 Dialogue window Isometry (on the left with a deactivated color display)
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12.5.4	 Isometry 3D (menu Presentation > Isometry 3D) 

This function generates three-dimensional displays of the power density distribution of a plane and all planes 
in false colors.
The presentation window is divided. On the left the caustic, on the right the power density distribution in a 
plane is displayed. The horizontal size of the single windows can be changed by drawing the separating bar 
by means of your mouse.
The graphics can be rotated along all three axis with the left mouse button and with the right mouse button 
they can be positioned in the window.

Change window size

1 2 3 4 5 6 7

Fig. 12.21:	 Dialogue window Isometry 3D

1 3D presentation of the 
plane

Inserts the 3D presentation of the power density distribution in the plane in the 
display window.

2 3D presentation of the 
caustic

Additionally inserts the 3D presentation of the caustic in the presentation window.

3 Magnification in the plane In the left part of the presentation window a magnification of the plane displayed 
on the right is inserted (the desired area can be clicked by means of the left 
mouse button in the right window).

4 Rotation Causes a rotation of both graphics along the z-axis.

5 Plane selection Here the plane, which is to be displayed, can be chosen (you can also choose 
the desired plane in the 3D caustic by means of the left mouse button).

6 Zoom Slide control for a continuous magnification of the presentation

7 Contour Slide control for a contour trimming along the power density.

Tab. 12.3:	 Explanation of selection and setting elements
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12.5.5	 Review 86 % or 2. moment (menu Presentation > Review (86%)/(2. moment)) 

For the radius definition there are two basic determination possibilities: 

•	 Determination of the beam radii according to the 86% - power definition, 
(see chapter 22.2.4 on page 145).

•	 Determination of the beam radii according to the 2. moment method (ISO 11146), 
(see chapter 22.2.3 on page 144).

Tab. 12.4:	 Result window 86% Review

Tab. 12.5:	 Result window 2. Moment Review

The parameters and results of the current selected plane are highlighted in blue. When the measuring signal 
only exceeds the zero level by a little bit, the measuring results are not shown in black, but rather in gray. In 
this case, check to see if the measuring values are reliable or need to be thrown out and the measurement 
repeated with different settings.

The entries for power, focal length, and wavelength as well as any comments can also be changed after the 
fact. For this purpose there is the button Apply in the menu item Measurement > Environment.
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12.5.6	 Caustic (menu Presentation > Caustic) 

The results of the caustic measurement can be displayed by means of the menu item Presentation > 
Caustic. On the left Fig. 12.22 on page 63 shows the measured beam parameter either on the basis of 
the 86%-radii or the 2. moment method evaluation according to ISO 11146. In the middle of the picture the 
graphic shows the caustic profile. The beam radii are depicted on the beam spread direction. On the right is 
a false color presentation of the measurement plane selected with the mouse shown together with numerical 
results of this corresponding plane.

Fig. 12.22:	 Dialogue window Caustic

The red line depicts a compensation curve according to the calculated fits which can be displayed via the 
check box Fit in the 2D presentation.

Compensating curve

In order to evaluate the caustic, a hyperbolic compensating curve (ISO 11146) is adapted to the measur-
ing values. This compensating curve describes the propagation of an ideal laser beam mathematically. The 
development of the compensating curve is theoretically determined by means of the following parameters:

•	 Standardized beam quality factor M² or respectively beam propagation ratio K
•	 z-position
•	 focus radius
•	 rayleigh length

Standardized beam quality factor M² (or respectively the beam propagation ratio K= )

The normed beam quality factor describes how well the affected laser beam can be focused in relation to the 
dominant mode. The basic mode represents the theoretically best possible beam and has a beam quality 
factor M² of 1. All other beams have higher M² values.
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Z-position

This value provides the position of the focus points in the z-position. As the compensation curve takes the 
measurement points into consideration, the calculated z-position is not necessarily located at the position, 
which has measured the smallest radius. 

Focus radius

The focus radius is the smallest beam radius in the caustic. Generally, this value is similar to the smallest 
value measured, but not necessarily.
Due to different reasons it may occur that the adaption to the measurement values was not carried out. This 
is the case if the compensation curve does not lie close to the measurement values. In this case the param-
eters of the adapted compensation curve are to be discarded. 

Rayleigh length

The Rayleigh length is a derived parameter and describes the distance in z-direction with regard to which the 
beam radius has increased by the factor √2 (=1.41) and concerning which the beam area has increased by 
the factor 2. The Rayleigh length increases with the focal length of the focusing optics and the beam quality. 
The doubled Rayleigh length is an approximate point of reference, up to which material thickness (metal) a 
procession is possible with the optic employed.

In order to make sure that the adapted values have a high significance, the measurement is to be carried out 
in a z-range of at least ±2 Rayleigh-lengths. As demanded in the ISO 11146 5 to 6 Rayleigh-lengths would 
be ideal. However, this demand is often confronted with the problem of quickly sinking power densities of the 
laser beam which is to be measured. In case of a distance of 2 Rayleigh-lengths from the focus the power 
density has sunk to just a quarter.

In this case the caustic measurement consists of a compromise between the desired measurement range in 
z-direction and the power density (signal-to-noise ratio) necessary for a perfect measurement.

Cyclic caustic measurements

When performing cyclic caustic measurements, it is useful to store settings for various display parameters in 
a data file. This data is available anytime and can be reloaded for a new measurement. For a quick check of 
the beam or when it is necessary to measure only part of the caustic.

Cyclic measurements are normally performed over a period of 2 to 3 minutes; by Ethernet communication 
much quicker. For measurements after laser or system servicing, you should use more planes to achieve 
greater accuracy in the results.

To start a measurement, saved caustic data is loaded from the settings file. This is done through the menu 
item File > Load Settings. The data is loaded after entering the desired file name. 
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Advanced (menu Presentation > Caustic > Advanced)

Fig. 12.23:	 Result window Results X,Y (2. moment)

For the examination of asymmetric beams the dimensions of the main axes of the beam can be determined. 
On the basis of these values the program also calculates direction dependent beam propagation factors as 
well as beam position values. The related curves are shown via the two check boxes radius x, y while the 
numerical values are provided by the result window.

Raw beam (menu Presentation > Caustic > Raw Beam)

Not relevant for MicrosSpotMonitor MSM.
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Review (menu Presentation > Caustic > Review)

This function checks whether the results and settings of the caustic measurement are within the reliable 
range. 

Borderline results
(in the measuring planes 
2, 4, 6, 7 and 8)

OK

Not ok

Fig. 12.24:	 Result window Measurement Review

Under “spread” the average standard deviation of the caustic fit according to the 2. moment method radii is 
stated. A “tick” () is set if the standard deviation is smaller than 3.5 % and if all of the measuring values lie 
within a range of ± 3 % standard deviation.
When the divergence receives a negative assessment (û) the affected measuring planes are also displayed. 
The displayed planes are arranged from left to right, starting with the greatest divergence and working its 
way down. This means that the plane with the greatest divergence (see Fig. 12.24 on page 66 Plane 2) will 
be the first one in front.

Valued functions Test criterion Positive evaluation  

Spread Average relative standard devia-
tion of the caustic fit according to 
the 2. moment method

Standard deviation < 3.5 %, all measurement values 
within a range of ± 3 % standard deviation

Fill factor Describes the ratio of the beam 
diameter to the lengths of the 
sides of the measuring window

In the range 0.35 – 0.7

Z-range Measuring range in z-direction At least 4 Rayleigh-lengths

Measurement planes Number of measurement planes 
per Rayleigh length

At least 3 measurement planes per Rayleigh length

(ZMin+Zr) < Z0 < (ZMax−Zr) Minimum measurement range 
above and below the focusing 
plane

The focus lies within the minimum measurement 
range and this range accounts for at least one Ray-
leigh length in every z-direction

Amplitude (>2 000) Signal control Above 2 000 counts

No Clipping (<4 000) Signal control Below 4 000 counts

Tab. 12.6:	 Criteria for the evaluation
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If all criteria are fulfilled, the measuring results have a high reliability. The absolute accuracy can not be stated 
from the standard deviation from the fits as all the systematic measuring errors as well as the accuracy of the 
calibration are additionally taken into account when it comes to the absolute error.

12.5.7	 Raw beam (menu Presentation > Raw-beam) 

Not relevant for MicrosSpotMonitor MSM.
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12.5.8	 Symmetry check (menu Presentation > SymmetryCheck)

This display menu checks the rotational symmetry of the power density distribution of a laser beam. It can, 
for instance in connection with the monitoring operation (Measurement > Single > Monitor), be used for 
the alignment of laser resonators.
In the following, the figures Fig. 12.25 on page 68 and Fig. 12.26 on page 68 show two examples for 
the possible results of a symmetry check at an elliptic beam and a circular beam.

 

Fig. 12.25:	 Dialogue window (menu Presentation > Isometry) power density distribution of an elliptic beam

The power density distribution of an elliptical beam as shown in Fig. 12.26 on page 68 together with the 
Symmetry check comes to the following results.

Fig. 12.26:	 Dialoque window Symmetry check in cartesian coordinates of an elliptic beam

The abscissa in Fig. 12.26 on page 68 shows the angle and the ordinate shows the beam radius with the 
intersection line at 86 % of the total power.
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Fig. 12.27:	 Dialoque window Symmetry check in polar coordinates of an elliptic beam

On the screen the curves appear in different colors. The radius is indicated in pixel coordinates. The mini-
mum as well as the maximum of the radius values can be chosen. On the right side the standard deviation of 
the different radius values are indicated. These values give detailed information on the symmetry of the beam 
distribution. 

Well aligned resonators reach standard deviations in the range of 3 % to 5 %. Partially, values in a 1 % and 
2 % range are possible. 
A presentation in polar coordinates is also possible (Fig. 12.27 on page 69). The drawn in lines contain 
86 % up to 10 % of the detected power. On the screen the graphs have different colors. X- and y-axis scale 
in pixel values.

12.5.9	 Fixed contour lines (menu Presentation > Fixed Contour Lines)

The contour lines are displayed with different power levels. Intersection lines are selected with: 86 %, 80 %, 
60 %, 40 %, 20 % and 10 % of the total power. 
In this presentation it is also possible to measure distances by clicking the start and end points with the 
mouse.

Fig. 12.28:	 Dialoque window Fixed contour lines
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12.5.10	 Variable contour lines (menu Presentation > Variable Contour Lines)

Here the spatial power density distribution is displayed by means of freely selectable contour lines. Not only 
intersections in x- and y- direction but also in power density coordinates (A/D-converter-counts) can be car-
ried out. The position of the intersections is settable by means of a slide control or the keyboard.

Fig. 12.29:	 Dialoque window Variable contour lines

Setting by means of the keyboard:

•	 For the x-direction by means of the key x in order to increase the value and <shift> x in order to de-
crease it.

•	 For the y-direction by means of the key y in order to increase the value and <shift> y in order to de-
crease it.

•	 For the power density (intensity) by means of the key i in order to increase the value and <shift> i in 
order to decrease it.

In the range of the left hand lower corner the current intersection coordinates, the power densities, the radius 
generated by the intersection as well as the relative volume are displayed. The values are calculated basing 
on the correctly entered laser power.

In the right hand upper corner it is possible to switch the scaling. Below it, there is an input field where the 
desired power loss (-inclusion) can be entered. This value correlates to the given power levels in the window.

In addition to these functions, this window also offers plenty of additional information on the conditions under 
which measurements are taken. The amplification, resolution number, and the software version used for 
measuring are all displayed while measuring as well.
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One click on the CCD Info button will open a window with additional information on the device parameters 
such as trigger mode, trigger delay, integration duration, magnification, and focussing optic type.

Fig. 12.30:	 Display window CCD Info
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12.5.11	 Graphical review (menu Presentation > Graphical Review)

The display window Graphical review offers many possibilities to display the measurement values of the 
single measurement planes. In total this window can present 20 different graphs. The possible selections for 
the x- and y-coordinates are shown in the Tab. 12.7 on page 72. 

y-axis x-axis

Radius Power

x-position Time

y-position Plane

Angle Position

Ellipticity

Tab. 12.7:	 Selections for the x/y coordinates

Fig. 12.31:	 Display window Graphical review – Example for assessment of a time series - radius/time

 
See chapter 12.4.9 on page 54, Section „Manual caustic measurement as time series (menu Measure-
ment > Caustic > Manually adjusted)“.

12.5.12	 Systemstate (menu Presentation > Systemstate)

Not relevant for MicrosSpotMonitor MSM.
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12.5.13	 Evalution parameter view (menu Presentation > Evalution Parameter View)

In the directory “System“ in the LDS installation file (C:\Program\Primes\LDS2.98\System) you can find 
predefined parameter files for the raw beam retrograde calculation (RawBeamParams.eval) and the caustic 
evaluation (beamparams.eval). These can be pulled up under the menu point Presentation > Evaluation 
Parameter View.

Fig. 12.32:	 Display window Evalution Parameter View with opened parameter file

The desired parameters and their limit values can be stipulated by means of the program PRIMES-EvalEditor 
and can then be saved in the evaluation parameter file (*.eval). The program is automatically installed when 
the LDS-setup is carried out. 

Fig. 12.33:	 Dialoque window EvalEditor with loaded *.eval-file
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The evaluation parameter file can only be displayed if the file BeamControls.xsd is located in the 
same directory (C:\Program\Primes\LDS2.98\System)!

12.5.14	 Evaluate document (menu Presentation > Evaluate doc)

The evaluation function compares selectable beam parameters and their adjustable limit values with the 
results of a current or a saved measurement.
Under the menu point Presentation > Evaluate doc of the LDS, the following dialog window is opened:

Fig. 12.34:	 Dialoque window Evaluate Document for loading an evaluation file

The button Open Doc opens a file selection window that allows to choose a saved measuring file (*.foc).

The button Open Profile opens a file selection window for choosing an evaluation parameter file (*.eval).

The button Evaluate triggers an evaluation (see Fig. 12.35 on page 75). The single evaluation parameters 
and the result of the evaluation are displayed. The overall evaluation (Result) of all results is displayed by 
means of a traffic light symbol.
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Evaluation Criteria: Only if all single evaluations are ok, the overall evaluation is displayed in green in the traffic 
light symbol.

Fig. 12.35:	 Dialoque window Evaluate

In case the warning or limit values are exceeded, this has an influence on the color display of the traffic light 
symbol. As soon as a warning value is exceeded or fallen short of, the yellow circle is filled. If the limit values 
(min/max) are exceeded or fallen short of, the red circle is filled. The actual values in the table of the evalua-
tion window are marked in color as well.

0WarnMin MaxWarn

Limit values(+)(−)

Traffic light color
Green YellowYellowRed Red

Fig. 12.36:	 Traffic light colors when warn- and limit values are exceeded

The overall result of the evaluation can be saved by means of the button Save.
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12.5.15	 Color tables (menu Presentation > Color Tables)

Different color charts are available. It is possible to switch back and forth between the color charts. Thus the 
assignment of A/D converter values and different color scales can be varied. This is important for the false 
color presentation.

Three settings are possible:

•	 Linear color table (basic setting)
•	 Color table analogue to the root function
•	 Color table analogue to the fourth root function

These functions can especially be helpful as far as the analysis of slight variations near the zero level are con-
cerned; e.g. the analysis of diffraction phenomena.

Fig. 12.37:	 Dialoque window Color Setup – Linear color table and 2nd root color table

12.5.16	 Toolbar (Menu Presentation > Toolbar)

The toolbar can be shown or hidden by clicking Presentation > Toolbar in the menu.

Fig. 12.38:	 Showing or hiding the toolbar
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12.5.17	 Position (menu Presentation > Position)

This menu can be used to move the device to its parked position.

Fig. 12.39:	 Dialoque window Postition

12.5.18	 Evaluation (option) (menu Presentation > Evaluation)

By means of this evaluation function, you can compare and evaluate different parameters of the measured 
caustic (.foc-file) with specified limit values (.pro-file). The evaluation result is displayed optically with an LED 
symbol (red=bad, green=good). The overall result (field Conclusion) is only considered as good provided that 
all results are within the critical parameters ( ).

Fig. 12.40:	 Dialoque window Evaluation

The parameters, the limit values and the identification of critical values are purported in a profile file (text file, 
please see the example file in Fig. 12.41 on page 78).
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Fig. 12.41:	 Example for a profile file

An evaluation is carried out as follows: 

1.	 Click the button Open Doc and choose your measuring file (.foc-file). 
2.	 Click the button Open Profile and choose your profile file (.pro-file). 
3.	 Choose the desired radius definition in the selection Caustic. 
4.	 Click on the button Evaluate.
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12.6	 Communication

12.6.1	 Rescan bus (menu Communication > Rescan bus)

This menu can be used to reconnect a device that was connected previously.

12.6.2	 Free communication (menu Communication > Free Communication)

By means of this menu you can control the communication via the PRIMES bus. Moreover, the settings for 
the communication are made here (see chapter 11.3.2 on page 31).

 

Fig. 12.42:	 Dialoque window Communication > Free Communication
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12.6.3	 Scan device list (menu Communication > Scan device list) 

Every PRIMES device has a certain bus address. If a device is supposed to be controlled by means of the 
LaserDiagnosticsSoftware LDS, the address has to be entered here. Moreover addresses can also be added 
or deleted in this menu.

Fig. 12.43:	 Dialoque window Scan device list

The following addresses for all PRIMES devices may be listed in the device list: 
80, 92, 112, 113, 114, 144, 145, 152, 161, 168
For the MicroSpotMonitor MSM, the address 161 must be entered.
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12.7	 Script (menu Script)

By means of scripts complex measurement procedures can be controlled automatically. Scripts are pro-
grams which are written in several script languages. Scripts are almost exclusively provided as source files in 
order to enable an easy editing and adjustment of the program.

12.7.1	 Editor (menu Script > Editor) 

By means of the script editor you can draw up scripts which can control, for example, complex measuring 
procedures automatically. An example is given in Fig. 12.44 on page 81 – the beam find procedure with 
the MicroSpotMonitor MSM. 
In order to open the script, the Open symbol has to be clicked, then a file can be chosen and played by us-
ing the button . The button  stops and  ends the script.

Fig. 12.44:	 Dialoque window Script – Script for the beam find procedure of the MicrosSpotMonitorMSM

12.7.2	 List (menu Script > List) 

Here all available scripts are listed.

Fig. 12.45:	 Display window List of Scripts

12.7.3	 Python (menu Script > Python) 

Starts the Python editor. The graphical user interface is identical to the one depicted in Fig. 12.44 on page 
81. Python is a programming language with efficient abstract data structures and a simple but effective 
approach for an object-oriented programming. Python is not only suitable for scripts but also for a fast ap-
plication development. For programming with Python a separate PRIMES documentation is available.
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13	 Measurement

13.1	 Safety instructions

DANGER
Serious eye or skin injury due to laser radiation

During the measurement the laser beam is guided on the device, which causes scattered or 
directed reflection of the laser beam (laser class 4). The reflected beam is usually not visible. 
 
The MicroSpotMonitor MSM must not be operated in any of the available configurations 
without taking the following precautions.

X  Please wear safety goggles adapted to the power, power density, laser wave length and 
operating mode of the laser beam source in use.

X Wear suitable protective clothing and protective gloves.

X Protect yourself from laser radiation by separating protective devices (e.g. by using appro-
priate shielding).

DANGER
Serious eye or skin injury due to laser radiation

If the device is moved from its calibrated position, increased reflected radiation  
(laser class 4) may result during measuring operation.

X When mounting the device, please ensure that it cannot be moved, neither due to an unin-
tended push or a pull on the cables.

NOTICE
Damaging/destroying the device

Contamination and fingerprints on the protective window can lead to damage or shattering 
or splintering of the protective window during measuring operation.

X Do not touch the protective window.

X Regularly check the condition of the protective window and exchange it in case of pollution 
(see chapter 15.1, „Exchanging the protective window“, on page 109).

X Only operate the device with a clean protective window.

NOTICE
Damaging/destroying the device

Obstacles in the movement range of the MicroSpotMonitor MSM can lead to collisions and 
damage the device.

X Keep the movement range free of obstacles (cutting nozzle, pressure rolls, etc.).
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NOTICE
Damaging/destroying the device

Contamination can damage or destroy the optical components.

X Only open the device in a dust-free environment.

13.2	 Selection and change of measuring objectives

13.2.1	 Selection of the measuring objective

The selection of the right measuring objective is of crucial importance when it comes to the quality of the 
measurement with the MicroSpotMonitor MSM.

The measuring objective must be optimally matched to the wavelength, the numerical aperture and the focus 
size to be measured. Furthermore, the possible fields of application are limited by the sensor- and pixel size 
(see chapter 21.4.1 on page 121).

10x + BPE

5x + BPE

3.3x + BPE

10x

5x

3.3x

Focus diameter in µm

1 10 100 1000

3,3x

3,3x+SWV

5x

5x+SWV

10x

10x+SWV

Spotdurchmesser in µm
1 10 100 1000

Fig. 13.1:	 Fields of application of the measuring objectives

In Fig. 13.1 on page 83 the field of application of different measuring objectives is depicted. The figure al-
lows a quick first selection of the correct measuring objective.
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The following table contains the limits that have to be observed when it comes to standard objectives as well 
as further objective data.

Standard

Objective NA F Max. measuring window Min. resolution Min. beam diameter Max. beam diameter

3.3x 0.1 5 1.4 mm 1.4 μm 30 μm 1 mm

5x 0.2 910 μm 0.9 μm 20 μm 650 μm

10x 0.2 2 510 μm 0.5 μm 11 μm 350 μm

With beam path extension (BPE)

Objective NA F Max. measuring window Min. resolution Min. beam diameter Max. beam diameter

3.3x 0.1 5 800 μm 0.8 μm 17.5 μm 550 μm

5x 0.2 550 μm 0.5 μm 12 μm 380 μm

10x 0.2 2 320 μm 0.3 μm 7 μm 220 μm

With alignment objective (AO)

Objective NA F Max. measuring window Min. resolution Min. beam diameter Max. beam diameter

3.3x 0.1 5 4 mm 3.9 µm 90 µm 2.8 mm

5x 0.2 2.75 mm 2.7 µm 60 µm 2 mm

10x 0.2 2 1.6 mm 1.6 µm 35 µm 1.1 mm

Tab. 13.1:	 Measuring objective data

NA = numerical aperture
F    = focusing value (see Fig. 13.5 on page 87)

On the basis of this table, a suitable measuring objective can be selected. The values apply for a wavelength 
of 1 064 nm (the values slightly differ with other wavelengths). 
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13.2.2	 Exchanging the measuring objective

1.	 Unscrew the two knurled screws (see Fig. 13.2 on page 85).
2.	 Remove the measuring objective upwards.
•	 Please note that the measuring objective is fixed by two dowel pins and does not tilt during removal.

Knurled screws

Dowel pins 2x

Fig. 13.2:	 Measuring objective

NOTICE
Component susceptible to electrostatic discharge

The EEPROM can be destroyed by an electrostatic discharge.

X Do not touch the contacts of the EEPROM as well as the contact pins (see Fig. 13.3 on page 85).

X Put on an ESD armband before changing the measuring objective.

There is an EEPROM in the mount of the measuring objectives, which contains all the objective data neces-
sary.

Contact pins

Dowel pins 2x

Fig. 13.3:	 Measuring objective – contacts and contact pins

3.	 Place the measuring objective from above on the two dowel pins (see Fig. 13.2 on page 85).
4.	 Press the measuring objective vertically down to its stop.
•	 When inserting, make sure that the measuring objective does not tilt.
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13.2.3	 Damage thresholds

The operating limits of the MicroSpotMonitor MSM are determined by the damage thresholds of the optical 
components. As described in chapter 21.4.1 on page 121, two different cases have to be considered.

NOTICE
Damaging/destroying the measuring objective

Power densities which are too high can destroy the measuring objective.

X Please mind that the power density I is smaller on the first lens  
~10 MWatt/cm² (cw) or ~100 MWatt/cm² (pulsed) respectively.

X The medium power should not exceed 250 Watt.

The power density I is calculated according to the following formula:

Fig. 13.4:	 Formula for calculating the power density I

•	 If the focus is placed below the measuring plane (too close to the measuring objective), the power den-
sity rises at the first lens of the measuring objective.

•	 If the focus is above the measuring plane, an intermediate focus develops inside the device. If the laser 
beam focus is too far above the measuring plane, the intermediate focus can develop in areas in which 
the beam power has not been sufficiently decreased. This can damage the image-sided beam path.

The size and position of the range in which the focus is to be positioned before the first measurement de-
pends on the measuring objecive selection, the used wavelength as well as on the type of focusing.

The diagram in Tab. 13.2 on page 87 shows that the upper limits for high-magnification measuring objec-
tives are much narrower than those with a 3.3-fold magnification.

The lower limit for convergent beams depends on the power density of the laser beam on the first lens. This 
is a function of the laser power, the focusing, the M², as well as the raw beam diameter.
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The graphs in Tab. 13.2 on page 87 and Tab. 13.3 on page 88 can be used to estimate the minimum 
distance.

Measuring plane distance  
PRIMES 10x-h without BPE

Distance between focus and measuring objective in mm

F = 5

F = 10

F = 15

F = 20

F = 30

20
0

0,5

1

1,5

2

2,5

3

3,5

4

4,5

5

30 40 50 60 70 80

B
ea

m
 r

ad
iu

s 
on

 th
e 

fir
st

 le
ns

 in
 m

m

Measuring plane distance 
PRIMES 3,3x-s without BPE

Tab. 13.2:	 Estimatation by the focusing value F for 1 064 nm and 532 nm

The diagram in Tab. 13.2 on page 87 shows the dependence of the beam radius on the first lens with the 
focusing value F and the distance of the focus from the first lens of the measuring objective.

The focusing value F can be determined by means of the following formula:

Fig. 13.5:	 Formula for calculating the focusing value F

f   = Focal length of the focusing lens
ds = Raw beam diameter
Θ = Full divergence angle
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Tab. 13.3:	 Estimatation by the focus radius for 1 064 nm and 532 nm

The diagram in Tab. 13.3 on page 88 shows the dependence of the beam radius on the first lens with the 
wavelength, the focus radius, and the distance of the focus from the lens.

The beam radii are estimated by means of the beam parameter product BPP.

Fig. 13.6:	 Formula for calculating the beam radii by the beam parameter product BPP

w0 = Beam radius
Θ  = Full divergence angle
λ   = Wavelength
M2 = Beam quality factor

In Tab. 13.3 on page 88, the beam quality factor M² was assumed to be 1.

The dependencies can be summarized as follows: 

•	 When it comes to strongly divergent beams, e.g. with a focusing with small focal lengths, small focus 
radii develop. In order to be able to achieve a sufficient resolution on the camera chip, the 10-fold mea-
suring objective is necessary. This objective also has a greater numerical aperture. 

•	 When it comes to laser beams with a beam quality factor M² = 1-2, small focus radii also occur with 
small divergences. This may lead to damages of the entry lens when long focal length objectives are 
used.

•	 When it comes to laser beams with large beam quality factor M² values, high power values occur. They 
are, however, not so critical due to the large focus radii. The spot diameter on the entry lens should 
always be greater than 1 mm.
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13.3	 Prepare measurement

The following check lists should help you to realise the most important conditions for a measurement and to 
carry out all necessary settings of the LaserDiagnosticsSoftware LDS.

13.3.1	 Check list measurement settings

 The device is stable and fixed.

 The movement range (z-axis) of the measuring device is free of obstacles.

Tab. 13.4:	 Check list safety precautions

13.3.2	 Check list measurement settings

LDS Menu Path Action

Measurement > Environment  Enter the focal length

Measurement > Sensor param-
eters




Preset 64 pixel for the resolution x
Preset 64 pixel for the resolution y

Measurement > CCD Settings 



Select the trigger mode Cw/Quasi-cw Measurement
Select the CCD mode Measuring data
Select the correct wave length

Measurement > Single  Activate the checkbox Optim.

Measurement > Caustic 


Activate the mode Automatic
Activate the checkbox Optim.

Measurement > Option 


Preset the fillfactor Max: 0.7 Min: 0.5 Ref: 0.6 
Analyse Settings: Activate the checkbox Enable adjust nullevel

Tab. 13.5:	 Checkliste Messeinstellungen
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13.4	 Flowchart of a measurement

13.4.1	 Prepare measurement
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13.4.3	 Perform caustic measurement
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13.5	 Perform measurement settings in the LaserDiagnosticsSoftware LDS

The following explanations of the configuration options should help you to make the right settings for the 
respective task.

The following chapters highlight important configuration options in color:

Color Meaning

Red This setting must always be set as shown.

Yellow This setting is dependent from the desired operating mode (CW, pulse, single pulse, measurement 
series, etc.).

Green This setting must be carried out before each measurement. The settings depend on the specific mea-
surement task, such as the wavelength, the laser power or the geometry of the laser beam.

Tab. 13.6:	 Color meaning of the setting options
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13.5.1	 Sensor parameters (menu Measurement > Sensor parameter)

Adaptable squares

Z

Y

Fig. 13.7:	 Dialogue window Sensor parameters

Mechanical limits

By pulling the turquoise square with the mouse pointer you can restrict the movement range of the y- and z-
axis. Therewith you can prevent damages in case other components reach into the movement range of your 
device. The maximum value corresponds to the value Y3 and Z3.

Resolution

Here you can enter the number of pixels in the measuring window, ranging from 32 x 32 to 256 x 256 pixels.
Generally, 64 pixels per line and a total of 64 lines is sufficient. Please keep in mind that the more pixels there 
are, the longer the measurement will take.	

Manual z-axis

With this function you can deactivate the z-axes of the measuring system. This is useful if you want to use 
external movement axes. In this case you can manually assign a z-value to every measurement plane in the 
dialogue window Single measurement.

Please find further information on the menu Menu Measurement > Sensor paramter in chapter 12.4.2 
on page 45.
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13.5.2	 Measuring environment (menu Measurement > Environment)

Fig. 13.8:	 Dialogue window Measuring Environment

Focal length

Stating the focal length is relevant for the evaluation of the caustic measurements. From the caustic process 
and the entered focal length the raw beam diameter on the focussing optic can be calculated.

Wave length

The wave-length is the basis for a correct determination of the beam quality factor M². There are the follow-
ing options:

•	 1.064 μm for Nd:YAG laser
•	 0.532 μm for Green laser
•	 0.355 μm for UV laser

A wavelength can also be typed in numerically.

Please find further information on the menu menu Measurement > Environment in chapter 12.4.1 on 
page 44.
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13.5.3	 Measurement settings (menu Measurement > Single)

Fig. 13.9:	 Dialogfenster Messeinstellungen

Controlling measuring modes (individual measurement, monitor, and video mode)

There is a total of three different measuring modes that can be selected here. In the Individual Measure-
ment and Monitor measuring mode, all necessary compensations (smear effect, diffusion) and exposure 
time adjustments are performed every time a new measurement is carried out. Valid measuring data is gen-
erated in this mode.

The measuring mode VideoMode does not produce valid measurement data. Here the exposure time is 
carried over from the last measurement and does not vary. Compensation measurements are not performed, 
making it unnecessary to consider or compensate for measuring artifacts such as smear effects.
Due to the “high” measuring frequency of about 5 Hz, this operating mode is particularly suited for use when 
aligning the device. The numeric results should not be interpreted absolutely, but rather always relative to 
each other.

Optical amplification (opt. ampl.)

This function activates the automatic adjustment of the exposure time of the CCD for every measurement. 
The function must be activated in order to keep the signal/noise ratio consistently high for a caustic measure-
ment. 
For special measuring applications, however, it might make sense to deactivate this function and set the ex-
posure time to a fixed value between 12 µs and 200 ms. Here it is important to ensure sufficient attenuation 
of the laser beam with the help of the fixed ND filter or the filter wheel.

Symmetrical

Once this function is activated, only rectangular measuring windows will be allowed. In cases where an ellipti-
cal or even a square laser beam is being measured, this function should be deactivated so that the measur-
ing window can be optimally adjusted.

Please find further information on the menu Measurement > Single in chapter 12.4.8 on page 50.
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13.5.4	 Caustic settings (menu Measurement > Caustic)

Fig. 13.10:	 Dialogue window Caustic settings

Parameters (start number of the plane)

Under Start, the start number at which the measurement is initiated can be entered for the plane. By default, 
the start number is generally set to zero and should only be changed when you are measuring in an existing 
document and don’t want the existing measurement data to be overwritten. If, for example, you have mea-
sured a caustic with 21 planes and want to magnify the measuring area to the smaller z-values, you can set 
the start plane to 21 and modify the measuring area appropriately. The new measuring values will then be 
written into the existing document starting with plane 21.

In the Quantity selection field, the number of planes to be measured in the specified z range is set. The fol-
lowing should be considered here:

•	 Since the LaserDiagnosticsSoftware LDS always sets the measuring plane distances so they are equi-
distant (equal spacing) and the measuring area is almost always situated symmetrically around the focal 
point, an odd number of measuring planes should be selected. The focus plane is calculated based on 
the measuring plane and displayed in the caustic illustration.

•	 Beam measurement norm DIN 11146 specifies that at least 10 measuring planes should be measured. 
Furthermore, five measurements should also be taken within a Rayleigh length and the other beyond 5 
Rayleigh lengths. In order to meet all of the requirements with equidistant distribution, at least 17 mea-
suring planes must be measured in a range of ± 3 Rayleigh lengths. 

Mode (automatic and manual settings)

There are two different measuring modes for caustic measurement. In “Automatic” mode, the measuring 
system and the LDS determine the ideal measuring window position (x- and y-direction) for each measuring 
plane and the optimal measuring window size for the fill factor. Furthermore, the plane location in the z-direc-
tion is also calculated based on the specifications (number of measuring planes, measuring limits z-direction).

Especially when adjusting the measuring window size and the measuring window position in the x- 
and y-direction, the number of iterations (max. three per plane) can result in an extended measure-
ment duration.

It is therefore possible to change the measuring mode to “Manual Settings” for recurring measuring tasks 
and for repeating measurements. In this case, the measuring system will take the measuring window posi-
tions and measuring window sizes from the previous measurement or from a .ptx file. This reduces the mea-
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surement duration considerably, but does require that the location and parameters of the laser beam change 
only minimally.

Beam search

This selection field specifies which plane the caustic measurement should be started in. If the optional Beam 
Find function is activated in the Options dialog window, that is also the plane in which this function will be 
performed. When the Beam Find function is deactivated, this plane must be manually measured ahead of 
time to make sure that the laser beam is found.

Please find further information on the menu Measurement > Caustic in chapter 12.4.9 on page 54.



98 Revision 02/2019 EN

MicroSpotMonitor MSM

13.5.5	 CCD settings (menu Measurement > CCD Settings)

Fig. 13.11:	 Dialogue window CCD Settings

The wavelength, attenuation, and operating mode are all set in the CCD Settings dialog window.

Trigger modes

The appropriate settings must be configured here in keeping with the operating mode of the laser to be mea-
sured. Here it is important to consider that pulsed lasers with a pulse frequency of more than 500 Hz can be 
measured in cw mode. If, however, the operating mode is set to pulsed and a cw laser system is involved, 
the measuring device will always display the error message “Error Black Pixel Measurement” or “Time Out 
During Measurement” in reaction to a measurement request.

Delay

This function can only be used with a “triggered operation” trigger mode. The time the measuring system 
should wait between when it detects the trigger pulse and the start of the measurement is set here. Together 
with the function “Integration Duration”, defined “Windows” from the plus cycles can be measured (e.g. ex-
actly one pulse or parts of an ms pulse. The minimum delay is 12 µs.

CCD operating modes

Three different modes can be set here. If the Raw Data setting is activated, the measuring system will return 
the uncompensated data of the CCD when a measurement is requested. Especially with NIR irradiation, 
these can be riddled with measuring errors such as “smear effect” readout noise. Even the numeric beam 
data generated generated from this data will be affected by this. 
If a Background is selected as the operating mode, only correction data will be returned while measuring. 
Measuring Data mode should always be the default setting here though. Only when this mode is turned on 
can the measuring system deliver reliable measuring values.
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Integration duration

This function sets a defined integration duration. The optimizer must be deactivated before this can be ac-
complished, since otherwise the measuring device itself will optimize and thus change the integration dura-
tion. This function is also used mainly in measuring pulsed laser systems.

Filter wheel

Which filter is needed for measuring depends on the wavelength and the intensity of the laser beam being 
measured and the appropriate one must be chosen specifically for each measuring task. 
A filter can be considered suitable when all measuring planes of a caustic measurement can be measured 
using an exposure time between 18 ms (-20 dB) and 0.18 ms (-60 dB). Outside of these limits, the S/N ratio 
of the CCD declines, thus reducing the accuracy.

Wavelength

Due to the wavelength-dependent overall magnification of the camera-based measuring system, it is impor-
tant to check that the right selections have been made before each measurement. The wavelengths shown 
here represent the calibration points of the measuring objective. As a result of the achromatic properties of 
the measuring objective, a wavelength range between 1030 and 1100 can be achieved, for example, with a 
calibration point at 1064 nm without causing generating measuring errors.

General sequence control 

•	 Empty the CCD register
•	 Aim for the holding point in line a (line in which photo transfer takes place); if the trigger is set off during 

sub-pulse, repeat line a (-> NLC = NoLineChange)
•	 Wait for the trigger if necessary and repeat line a (NLC)
•	 Wait out the delay if necessary and repeat line a (NLC)
•	 Aim for the holding point in line a through sub-pulse (-> delete the charge in the photo diodes)
•	 Integration – no cycles (sliding the charges through the register) of CCD
•	 Cycles start again, a few AD cycles later: Photo transfer
•	 Read out the CCD register; when the addresses match (= desired pixels), the measuring value is for-

warded to the AD transformer.

The various signals going through the transfer output mark certain points in time during the sequence con-
trol:

Transfer signals Meaning

Do transfer Is high when the CCD is at the holding point in line a (referred to in this way, since photo 
transfer also takes place in this line – when it isn’t being suppressed by the NLC). 

Do transfer & Xend A short high-pulse, when we reach the end of line a.

Sub Is high as long as a sub-pulse is running.

Start done Is high when the CCD is ready for integration (or when waiting for the trigger) so when it 
is at the holding point in line a. Is low again when the CCD is read out. You could use the 
positive side to light the laser.

Wait for trigger Is high when the CCD is at the holding point in line a and is waiting for the trigger signal.
Is low as soon as the trigger is activated and the delay begins. Only a short high pulse 
occurs in untriggered operation. Could be used in addition to the trigger out connector to 
check triggering.

Integration done Is high as soon as integration is complete. Is low again when the CCD is read out.

Photo cycle Is high when the CCD is ready for integration. Is low as soon as integration is complete. 
During untriggered operation, the high phase returns exactly the integration time.

Tab. 13.7:	 Signals that can be sent through the transfer outlet

Please find further information on the menu Measurement > CCD Settings in chapter 12.4.5 on page 48.
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13.5.6	 Option (advanced user only) (menu Measurement > Option)

Fig. 13.12:	 Dialog window Option

Enable beam find process

The Beam Find function must be used for caustic measurement. This involves an algorithm that separates 
the measuring signal from the measurement artifacts (e.g. noise) via an adjustable trigger threshold and 
adapts the size of the measuring window to this signal. This algorithm is only executed in the beam search 
plane (Dialog window Caustic). On all other measuring planes, the measuring window size is determined us-
ing the fill factor. 
If this function is deactivated, the beam search plane must be manually “premeasured” in the measuring 
system. Otherwise the measuring system might end up positioning the measuring window on the edge of the 
measuring area where there is no measuring signal. This makes it impossible to take a meaningful measure-
ment. 
If you turn the Beam Find function off and have the measuring measure the beam search plane system be-
fore each caustic measurement, you can save about 20 sec of measuring time per caustic measurement.

Summary: This function should be activated by default and only deactivated by experienced users. Turning 
off this function can shorten the time for caustic measurements by about 15 %.

Fillfactor

The fill factor is the quotient of the beam diameter and the length of the sides of the measuring window. As 
long as the measuring signal is not cut off and there are no noise components in the measuring result and 
now errors in the offset determination, the fill factor won’t influence the accuracy at all. But since every real 
measuring signal is tainted with noise and since the precision with which the zero level of a measuring signal 
can be determined is finite, very small fill factors can lead to a high level of accuracy. Depending on how 
substantial the RMS noise is and the errors in the zero level determination of a measuring plane, the optimal 
fill factor value to produce the best possible mathematical result will be different. 
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For TopHat and Gaussian beam shaped laser beams, the fill factor should range between 0.5 and 0.7. If the 
beam has diffraction rings, however, and if these are located completely within the measuring window, the 
optimal value for the fill factor can be between 0.5 and 0.6.

By default, the value should be set to: “Max 0.7 Min 0.5 Target 0.6”. For extremely deformed beams, the 
value may be changed to “Max 0.6 Min 0.4 Target 0.5”.

Font size

The font size for the most important display window can be changed here.
It is set to 10 points at the factory.

Open windows

When the window opening function is activated, some basic windows are opened when the LDS is started. If 
you don’t want this to happen, the function can be deactivated.

13.5.7	 CCD info (menu Measurement > CCD Info)

The most important device data is shown in the menu Measurement > CCD Info. Here you can see the 
magnification information for the measuring objective and also check which beam path is turned on.
If obvious default values (1:1) are shown instead of the actual magnification, then please check the mounting 
of the measurement objective. 

Fig. 13.13:	 Window CCD Info
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13.5.8	 Single measurement (menu Measurement > Single)

This menu item is used for conducting single measurements. Settings for the measuring window position 
can be entered manually or automatically. The x- and y-axis measuring range of 2 mm x 2 mm at the device 
is much greater than the largest measuring window. It allows you to do a beam search manually or using the 
Scan function.

When a Scan is triggered, the MicroSpotMonitor MSM automatically tests the measuring range. When a 
point of maximum intensity is detected, the MicroSpotMonitor MSM automatically zooms to this point and 
adjusts the measuring window size. When the device has no x- or y-axis, the beam search function can be 
done automatically with item Find beam.

The system only searches the area of the set-up window at the selected z-position. Afterwards, the Beam 
Search window appears. If the beam search is successful, a measurement window of appropriate size and 
position is displayed in the test panel of the “Single Measurement” window. The beam can then be recorded 
using the Measure button. The size of the measurement window depends on the magnification of the objec-
tive. Influencing factors are objective, wavelengths, and operating mode (standard, beam path extension, 
and calibration mode).

Fig. 13.14:	 Dialogue window Measurement settings

During a manual beam search, the user can set the position and size of the measuring window within the 
mechanical limits himself. The selection is found in a pop-up menu, where you enter an x value for quadratic 
and/or x and y values for a rectangular measuring window. The position of the measuring window can be 
changed by clicking and dragging the frame using the mouse. The position of the window in the z-direction 
(height) can be changed using the z-sliding bar or by entering numerical values. The Zoom function allows a 
detail magnification of the measuring range.

A measurement is started with the Start button. The Monitor button starts periodic measurements based on 
current settings. The repetition rate depends on the spatial resolution and type of communications between 
the PC and the MicroSpotMonitor MSM.
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The video mode only functions when using ethernet communications. The MicroSpotMonitor MSM provides 
4 frames per second in video mode. Unlike the monitoring operation, only raw data is transmitted in video 
mode. 
If the detector is overdriven during a measurement (the appearance of red in the representation and/or an 
A/D-Converter value of 4 095 in a clear section indicates signal saturation), you should reduce the amplifi-
cation using the Amplitude slider Ampl. and repeat the measurement. Amplification is automatically regulated 
when optimization is activated. If necessary, filtering must also be increased using a neutral glass density 
filter.

The radiated power can be configured using the Power scroll bar. The reference value for the scroll bar is 
entered in the Measurement > Environment menu. The power density is calculated in relation to the power 
values set here. Up to 50 individual measurements can be recorded in a measurement file. This is relevant 
when measuring the beam caustic and for time or power series. It is possible to switch back and forth be-
tween the individual measuring planes.

With the button Copy the measurement settings (window size and position, power and amplification) can be 
copied from the previous measuring plane. 

By means of the option Averaging the average of the results of up to 50 single measurements per each 
plane is determined. There are different analysis algorithms available:

•	 Average determines the average value of the distributions measured
•	 Max. pixel determines the pointwise maxima of the distributions measured
•	 Max. trace determines the maximum traces of the distributions measured

During a measurement, the status of the measurement system is constantly displayed. These are:

•	 the current measuring plane
•	 the run of the reference cycle
•	 positioning the measuring head
•	 the measurement
•	 the data transmission – the progress is shown by means of the bar display

Fig. 13.15:	 Display window Monitor

By means of the button Stop you can cancel a running measurement (this does not disrupt movement along 
the z-axis). We recommend triggering a Reset cycle afterwards. Canceling will also end monitor operation. 
The Stop button can be used to stop the measurement. A Reset cycle should then be triggered before 
further measuring.
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13.5.9	 Caustic measurement (menu Measurement > Caustic)

The caustic measurement is a serial measurement where the z position is varied. The goal is to examine 
propagation in the propagation direction. The results are stored in different planes. A different z position 
is assigned to every measuring plane. As the beam radius as well as the power density change in every z 
position, the position as well as the size of the window and the signal strength can vary from plane to plane. 
These parameters are therefore individually adjustable in every measuring plane.

The caustic measurement itself can be carried out either manually or automatically. For the automatic caustic 
measurement the following has to be entered:

•	 the minimum and maximum z-position
•	 the number of planes that are to be measured
•	 the starting plane for the beam search

After finding the beam, the system then measures the beam at equidistant intervals and determines the 
focus length, focus radius, and beam parameter product. During manual measurement, all parameters are 
configured by hand following individual measurements. The caustic can then be manually measured. The 
measuring parameters can be stored by means of the menu item File > Save measurement preferences 
and can be loaded again upon request.

Prepare a caustic measurement

When positioning the MicroSpotMonitor MSM, the beam focus should be in the middle of the z-axis work-
ing area. Depending on device accessories or fittings, this is approximately 17 mm above the null position 
(35 mm for a standard device) of the integrated z-axis. The following values can be set globally:

•	 power
•	 magnification
•	 the value and averaging mode

There should be a minimum of ten measuring planes within the range of ±2 Rayleigh Lengths around focus 
point. There should be at least five with the range of ±1 Rayleigh Length around the focus point.

To conform with ISO 11146 standards, one should measure, at a minimum, over four Rayleigh Lengths. We 
recommend measuring over  ± 3 Rayleigh lengths in 21 planes.
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Automatic caustic measurement (menu Measurement > Caustic > Automatic)

Fig. 13.16:	 Dialogue window Caustic settings

During automatic caustic measurement, the minimum and maximum z-position is selected together with the 
number of measuring planes. The measurement cycle begins with an automatic beam search in the specified 
starting plane. The beam search only occurs within the area of the starting plane’s measurement window.

If you don’t want the search window size to take up the maximum space (depending on the lens), the 
window size can be adjusted, once the control box Maximize Window has been deactivated, by selecting 
Adjust in the menu. The Details menu point allows the user to configure the beam search parameters by 
changing the spacial resolution, threshold value, and minimum signal.

If automatic find beam needs to be left out to save time, it can be deactivated in the Options dialog 
window (Menu Measurement > Option) (activate check box Beamfind ).
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Manual caustic measurement (menu Measurement > Caustic) and (menu Measurement > Single)

Fig. 13.17:	 Dialogue window Caustic settings and Measurement settings

The manual caustic measurement consists of a series of individual measurements at various z-positions, with 
the results being stored in their own planes.

The z-distance for the individual planes should be about 1/200th of the focal length of the lens. For a lens 
with a focal length of 127 mm, this means a distance of about 0.5 mm to 0.6 mm. For a caustic measure-
ment with fifteen planes, the range on the z-axis should be about 8 mm.

The start plane and number of measuring planes must match the settings in the settings window-
Measurement > Single > Measurement settings .

To conduct a manual caustic measurement, follow these steps:

1.	 Delete the old data in the  Edit > Clear all planes  
dialog window or create a new document File > New.

2.	 In the Caustic settings dialog window, click on Manually adjusted (menu Measurement > Caustic).
3.	 Select the first plane in the  Measurement settings  dialog window (men Measurement > Single).
4.	 Configure the z-position in the  Measurement settings dialog window.
5.	 Configure the measurement window size and position in the  Measurement settings dialog window.
6.	 Perform a measurement in the configured pane.
7.	 Select the next plane and start again at Point 3.

Steps 3 through 6 can be repeated ten to fifteen times.
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Record a time series (menu Measurement > Single)

Fig. 13.18:	 Dialogue window Measurement settings

Recording a time series corresponds to manual caustic measurement, but with the z-position staying the 
same on all planes.

1.	 Delete the old data in the  Edit > Clear all planes  
dialog window or create a new document File > New.

2.	 Select the first plane in the  Measurement settings  dialog window (men Measurement > Single).
3.	 Configure the z-position in the  Measurement settings dialog window.
4.	 Configure the measurement window size and position in the  Measurement settings dialog window.
5.	 Perform a measurement in the configured pane.
6.	 Select the next plane and use the old settings by clicking the Copy button.
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14	 Troubleshooting

14.1	 Error during a measurement

When there is an error during data transfer, a processor in the measuring system failed or there was an error 
during program execution. Attempt to restart the system with the Reset button in the LaserDiagnoseSoft-
ware LDS. If this does not help, turn off and on the 24 V power supply for the bus system and start another 
“Reset Cycle”. If necessary, restart the computer.

14.2	 No measurement signal at the MicroSpotMonitor MSM

When there is no measurement signal detected, except for noise which is typically 270 - 300 counts at the 
MicroSpotMonitor MSM (the current number of counts can be found under the menu item Display > Vari-
able Contour Lines, recheck the device position. Besides wrong positioning a too high attenuation can 
cause the same problem.
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15	 Maintenance and service
The operator is responsible for determining the maintenance intervals for the measuring device.
PRIMES recommends a maintenance interval of 12 months for inspection and validation or calibration.
If the device is used only sporadically, the maintenance interval can also be extended up to 24 months.

15.1	 Exchanging the protective window

The measuring objective of the MicroSpotMonitor MSM can be optionally delivered with a protective window 
or a protective window with cyclone. The protective window in the beam entrance is a wearing part and can 
be replaced if necessary. Low levels of contamination of the protective window can be carefully removed 
when cooled with Isopropanol (observe the manufacturer‘s safety instructions). In case of heavy, non-remov-
able contamination or damage, the protective window must be replaced with a new one.

The protective window is coated with an antireflex coating and has low reflection values of less than 
1%. To avoid increased reflection values, use only original PRIMES protective windows.

Protective window diameter	 30 mm
Glass thickness			   1.5 mm
Order number			   801-004-054

15.1.1	 Safety instructions

DANGER
Severe eye or skin injury due to laser radiation

If the protective window is not correctly positioned, reflections can cause
directional laser radiation.

X Make sure that the new protective window is settled flat in the groove of the protective win-
dow holder.

CAUTION
Burns due to hot components

After a measurement the protective window is hot!

X Do not replace the protective window directly after a measurement.

X Let the device cool down for an adequate period of time. The cooling ime varies depending 
on the laser power and the irradiation time.

NOTICE
Damaging/destroying the device

Contamination and fingerprints on the protective window can lead to damage or shattering 
or splintering of the protective window during measuring operation.

X Only replace the protective window in a dust-free environment.

X Do not touch the protective window.

X When exchanging the protective window wear powder-free latex gloves.
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The protective window is located in the protective window holder of the measuring objective below the 
retaining ring or cyclone. The retaining ring or the cyclone are attached to the protective window using a 
spring-loaded bayonet lock with three locking pegs.

15.1.2	 Replacing the protective window

1.	 Follow the safety instructions in chapter “15.1.1 Safety instructions” on page 109.

2.	 Push the retaining ring down against the protective window holder, turn it counterclockwise until it stops 
and lift the retaining ring up and off.

3.	 Remove the old protective window from the protective window holder (e.g. with a suction cup) and dis-
pose of it.

4.	 Carefully place the new protective window into the protective window holder.
5.	 Position the locking pegs of the retaining ring in the openings of the bayonet lock.
6.	 Push the retaining ring down and turn it clockwise until it stops. 
•	 The bayonet lock is locked.

Protective window

Retaining ring

Protective window holder

Fig. 15.1:	 Components of the protective window holder
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15.1.3	 Replacing the protective window for cyclone

1.	 Follow the safety instructions in chapter “15.1.1 Safety instructions” on page 109.

2.	 Remove the compressed air hoses around the cyclone if necessary.
3.	 Push the cyclone down against the protective window holder, turn it counterclockwise until it stops and 

lift it up and off.
4.	 Remove the old protective window from the protective window holder (e.g. with a piece of adhesive tape) 

and dispose of it.

5.	 Carefully place the new protective window into the protective window holder.
6.	 Position the locking pegs of the cyclone in the openings of the bayonet lock.
7.	 Push the cyclone down and turn it clockwise until it stops. 
•	 The bayonet lock is locked.

Cyclone

Protective window

Protective window holder

Compressed air
connection

Fig. 15.2:	 Components of the protective window holder with cyclone
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16	 Storage

NOTICE
Beschädigung/Zerstörung der optischen Komponenten durch Verschmutzungen oder Stöße

Verschmutzungen können die optischen Bauteile beschädigen oder zerstören. Durch harte 
Stöße oder Fallenlassen können die optischen Bauteile beschädigt werden.

X The device must only be transported with a mounted transport lock.

X To avoid contamination, please cover the aperture with the provided lid or optical tape.

X Store the device in the original PRIMES transport box (option). 

Please note before storing devices with water cooling circuit:

NOTICE
Damage/destruction of the device caused by leaking or freezing cooling water

Leaking cooling water can damage the device. Storing the device at temperatures near or 
below freezing and without emptying the cooling circuit completely can damage the device.

X Empty the lines of the cooling circuit completely.

X Don’t use any compressed air to empty the cooling circuit.

X Even when the lines of the cooling circuit have been emptied, a small amount of residual 
water will remain in the device at all times. This may leak out and end up inside the device.
Close the connector plug of the cooling circuit with the included sealing plug.

X Store the device in the original PRIMES transport box (option). 

17	 Measures for the product disposal
Due to the Electrical and Electronic Equipment Act (“Elektro-G“) PRIMES is obliged to dispose PRIMES 
measuring devices manufactured after August, 2005, free of charge. PRIMES is a registered manufacturer in 
the German “Used Appliances Register“ (Elektro-Altgeräte-Register “EAR“) with the number WEEE-reg.-no. 
DE65549202.

Provided that you are located in the EU, you are welcome to send your PRIMES devices to the following ad-
dress, where they will be disposed free of charge (this service does not include shipping costs):

PRIMES GmbH 
Max-Planck-Str. 2 
64319 Pfungstadt 
Germany
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18	 Declaration of conformity
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19	 Technical data

Measurement parameters

Power range 1  mW – 200 W (optional 500 W with water cooling)

Wavelength range 257 – 272 nm (on request)

340 – 360 nm

515 – 545 nm

1 030 – 1 090 nm

Beam diameter min. 20  µm – max. 1 mm  
(depending on the measuring objective)

Determined parameters

Focus position x, y, z yes

Focus radius x, y yes

Beam quality factor M² yes

Raw beam diameter with focussing element yes

Beam parameter product BPP yes

Divergence angle yes

Power density distribution 2D, 3D

Device parameters

Measuring range x-, y-direction 0.02 – 2 mm (depending on the measuring objective)

Measuring range z-direction 35 mm or 120 mm

Integrated variable attenuation (option) Filter wheel with 5 OD filter (OD 0 – 5)

Supply data

Power supply 24 V DC ± 5 %, max. 1,8 A

Compressed air for cyclone (cleaned, free of water and oil) 0,5 bis 1 bar

Cooling water pressure 2 bar primary pressure with an unpressurized outflow,  
max. 4 bar

Min. Cooling water flow rate 1,5 l/min

Cooling water temperature Tin
1) Dew point temperatur < Tin < 30 °C

1) Please consult with PRIMES before doing anything that does not comply with this specification.

Communication

Interfaces RS485/Ethernet

Dimensions and weight

Dimensions (L x W x H) Length: 427 mm +12 mm movement range + connector
Width: 202 mm
Height: 181 mm + 35/120 mm movement range + projec-
tion depending of the measuring objective used

Weight 15 kg
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Environmental conditions

Operating temperature range 10 – 40 °C

Storage temperature range 5 – 50 °C

Reference temperature 22 °C

Permissible relative humidity (non-condensing) 10 – 80 %
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20	 Dimensions
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21	 Appendix

21.1	 Insert fixed OD filter (option) in the inspection chamber

1.	 Turn off the laser source.
2.	 Ensure that moving parts, e.g. robot arms, etc. are at a standstill and that they cannot be set in motion 

unintentionally.
3.	 Switch off the power supply of the MicroSpotMonitor MSM.

NOTICE
Damaging/destroying the optical components

Contamination can damage or destroy the optical components.

X Only open the inspection chamber in a dust-free environment.

4.	 Unscrew the knurled screw on the cover and open the cover.
5.	 Insert the fixed filter into the slot provided.
•	 The insert has different guides so that the fixed OD filter can only be inserted in one position.
6.	 Close the cover and screw in the knurled screw:
•	 Check the secure fit of the cover.
•	 The cover must fit flush with the housing, so that no dust or dirt can get into the inspection chamber.

Fixed OD filter

Cover

Inspection chamber

Fig. 21.1:	 Insert fixed OD filter into the inspection chamber
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21.2	 File “laserds.ini” – an Example

The contents of a laserds.ini file are shown below. Some information is gained regarding the startup settings 
for the system – such as:

•	 default serial interface.
•	 default settings for beam find, such as threshold and spatial resolution for the search.

The settings can be changed in a Windows® Editor. Close the LaserDiagnoseSoftware LDS before making 
changes in the laserds.ini file. Otherwise, the changes will not be activated and be reset when the program 
closes.

[Version]
No.=17

[Window]
left=10
top=10
right=1183
bottom=948

[Comm]
Data_Transfer_Mode=0
Port=
HighBaudrate=1
escan=161,168,152,144,145,
192,112,113,80

[Ethernet]
IP=0.0.0.0
Port=6001
MAC Address=00-00-00-00-00-00
[Device]
Type=
ID=-1

[Adresse]
Own=64

[Private]
Mode=0

Flag1=1111
Flag2=0
Flag3=0
[File]
Default=

[Laser]
Wellenlaenge=0.01060000
Drehzahlnr=0
Kamerachip=0
Laserleistung=6000.00000000
Brennweite=127.00000000
StrahlsucheTrigger=150
Strahlsuche Trigger für Pyro=150
Strahlsuche Trigger für Photo=50
StrahlsucheProzent=35
Funkvorhanden=1
Detektortyp=1
SperrbereichY0=8.00000000
...
...
Autoscaleon=1

Extern Z-Axis=0
Tip twisted=0

[Detectorparameter]
Detector 0 Tau1=10
Detector 0 Scale1=-0.1
Detector 0 Tau2=3500
Detector 0 Scale2=0.1
Detector 0 Tau3=0
Detector 0 Scale3=0
Detector 0 Name=Pyro-FM-1
Detector 1 Tau1=0
...
...

[TriggerModi]
TriggerMode 0=Dauer-Trigger
TriggerMode 1=Trigger mit Delay
und folgender Pulslänge
...
...
[Interface]
Startup=0
[Skript]
Startdatei=
[Output]
Out0=Port 0
Out1=Port 1
...
...

[Input]
In0=Port 0
In1=Port 1
In2=Port 2
...
...

[Multimon]
Rescan=32,33,128
Radius=1.

[Kaustik]
FuellMin=0.25
FuellMax=0.4
FuellSoll=0.35
[YAG-Kamera]
Trigger-Mode=0
Trigger-Level=0
Trigger-Delay=0
Pulslaenge=1
CCD-Mode=30

[Export]
Setting=0
[Service]
Firmenadresse=
Servicetechniker=

[BusProtokoll]
Befehl_Nr=0
Datei_Nr=1
Protokoll=0

[SchlittenKonstante]
Offset=1
OffsetFromBottom=5.9

[Process Data]
Mode=0

[View]
Font Size=10
Recent File1=
Recent File2=
Recent File3=
Single Window PositionX=0
Single Window PositionY=0
Caustic Window PositionX=0
Caustic Window PositionY=0
Sensor Window PositionX=0
Sensor Window PositionY=0
Envi Window PositionX=0
Envi Window PositionY=0
MSM Settings Window PositionX=0
MSM Settings Window PositionY=0
MSM Info Window PositionX=0
MSM Info Window PositionY=0
Free Window PositionX=0
Free Window PositionY=0
Power Window PositionX=0
Power Window PositionY=0
Show Measuring Windows=1
[Measurement]

Beamfind Iteration=3
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21.3	 Description of the MDF file format

The MDF file format is a simple ASCII-format which includes the main data of a beam measurement – the 
spatial power density distribution. MDF stands for “mailable data format”. 
By means of this standardized format conversion problems between different evaluation programs are sup-
posed to be reduced and a safe data transmission, e.g. per e-mail, is supposed to be ensured.

The files are arranged as follows: 

1st line: 		 MDF 100 (file identifier)
2nd line: 		 Number of image points: in x-direction in y-direction
3rd line: 		 Size of the measurement range: length in x (mm) length in y (mm)
4th line: 		 Position along the beam axis: z-position (mm)
5th line: 		 Transversal position of the center of the measurement range: x-pos y-pos (mm)
6th line: 		 Amplification of the measuring signal: enhancement (dB)
7th line: 		 Number of averages: number
8th line: 		 Offset value displayed by the measuring device: offset-value
9th line: 		 Wavelength-value
10th line: 	 Power value
11th line: 	 Focal length value
12th line: 	 Date, time value

In the following lines the data can be found. 
There is a maximum of 80 characters per line. 

Comments

Comments are inserted as additional lines, into the lines after the file identifier. 
The comment lines each start with a semicolon.

Example:

MDF100
;This is an example. 
;These lines are a comment.
64    64
2    2
11
...
...
1
10
10 10 10 10 10 10 10 10 10 10
11 12 13 14 15 16 17 18 19 20
20 20 20 20 20 18 16 14 12 10
....
....
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21.4	 Optical components

The MicroSpotMonitor MSM is a camera-based measuring system. Depending on the application, up to 7 
different optical components can be in the beam path.
The purpose and functioning of individual components is described in the following chapters.

Measuring plane
Upper limit

Mirrors

Trigger

Filter wheel (option)

Lower limit

Measuring  
objective

Beam path extension (BPE)

Absorber

Laser beam

Absorber

Alignment objective (AO)

CCD sensor

Fixed OD-filter (option)

Prisms

Fig. 21.2:	 Example of the optical design of the MicroSpotMonitor MSM
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21.4.1	 Measuring objective

The measuring objective is a lens system designed to reproduce a specific plane “above” the measuring 
objective onto the CCD sensor. “Above“ in this case, means that the plane is outside the MicroSpotMonitor 
MSM.
This non-contact measurement offers the advantage that even very high power densities (GW/cm²) can be 
detected. The measuring objective makes it possible to enlarge the beam and thus to image a sufficient 
resolution on the CCD sensor.

Fig. 21.3 on page 121 shows a diagram of the measuring objective. It includes all important parameters.

Measuring plane distance

Main planes
H

f

y x

a
a‘

H‘
Object planes

Picture plane

Optical axis

Fig. 21.3:	 Illustration of a defined plane with a measuring objective

The main planes H and H‘ in the measuring objective or image space are auxiliary quantities in order to 
combine any number of optical components into one unit. The focal length f, offset distance a, and image 
distance a‘ are measured from the intersection of the main planes with the optical axis (cardinal point).

The dimensions x, y and the measuring plane distance are important auxiliary quantities. They establish the 
relationship between the optics and their socket more exactly the socket edge.

The projection of the measuring objective is calculated according to the following formula:

(1.1)

The focal length f is dependent on the wavelength and, as a result, the image distance a’ is dependent on 
the object distance a.

The magnification of the measuring lens is calculated from the quotient of a and a’:

(1.2)

The combination of the two formulas gives β a dependence on the image size a’ and the focal length f. The 
focal length is determined by selecting a measuring objective and the image distance is determined by the 
construction of the measuring device.
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The choice of the measuring objective depends on the geometry and the beam parameters of the laser 
beam to be measured. The sensor area of the CCD sensor is 4.76 mm x 5.58 mm.
According to the ISO standard 11146, the measurement must be carried out for at least 4, more preferably 6 
rayleigh lengths.

According to the following formula the sensor area must be at least 5 times larger than the expected focus 
diameter.

ωσ(z) = ωa0
(1.3)

Once the appropriate measuring objective has been selected, the MicroSpotMonitor MSM recognizes the 
assembled measuring objective via an electronic coding on the holder of the measuring objective and adjusts 
the available measuring windows. 
If, for example, the maximum square measurement window size in a 1:1 figure on the CCD sensor 4 mm x  
4 mm, it should be reduced to 0.4 mm x 0.4 mm at a magnification of 10:1.

The inlet aperture of the MicrosSpotMonitor MSM can easily be aligned with the optical axis of the laser 
beam within a range of 2 mm x 2 mm using an alignment tool (see chapter 7.2.2 on page 19). The path 
of movement of the x and y axis of 2 mm makes it possible to position the laser beam precisely on the CCD 
sensor.

Pixel

CCD sensor field

Magnification 1:10

Measuring
objective 10:1

5,58 mm = 1360 pixel

2 mm

2 mm

4,
76

m
m

 =
 1

02
4 

pi
xe

l

Fig. 21.4:	 Schematic illustration of a measuring plane on the CCD sensor

Fig. 21.4 on page 122 shows schematically the projection of a measuring plane onto the CCD sensor. The 
reticule on the left shows the measuring area, which can be measured with the x- and y-axis. This can also 
be done automatically with the help of the Scan command.
Within the measuring area, a measuring window can be positioned (size depending on measuring objective). 
On the right, the CCD sensor field is displayed. The measuring window, which has an edge length of 0,4 mm 
(in the object level), is projected to the chip with a 10-fold magnification.
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Positioning the focused laser beam over the MicroSpotMonitor MSM

The image characteristics of the measuring objective make it necessary to position the laser beam focus in a 
specific range over the measuring objective. 
Formula (1.1) shows, the further the focus is positioned over the measuring objective (afocus), the closer it is 
projected behind the measuring objective (a’focus).

Upper limit

If the focus is located too high above the measuring objective, a focus on the image-sided beam path can 
develop. Together with too high beam intensities, the optics might be damaged.

Measuring plane

The beam distribution of the measuring plane is displayed on the CCD sensor.

Lower limit

If the focus is too close to the measuring objective, it can – depending on the type of focusing and the power 
used – damage the entrance lens.

Laser beam

Measuring plane

Measuring plane distance

Measuring objective

Upper limit

Lower limit

Fig. 21.5:	 Measuring range of the MicroSpotMonitor MSM

The size of the range in which the focus is to be positioned before the first measurement depends on the 
chosen objective, the used wavelength and the type of focusing. The measurement range lies within an up-
per and a lower limit.
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Prisms

After the measuring objective, the laser beam strikes three uncoated quartz glass prisms which attenuate the 
laser beam.

Measuring  
objektiv

Fixed OD flter 
(option)

Prisms

z

x

x

Fig. 21.6:	 Section of the beam path of the MicroSpotMonitor MSM

The reflection is described with the Fresnel formulas. They describe the so-called reflection respectively 
transmission ratio of light at surface boundaries.

(1.4)

: Reflection ratio of vertically polarized light.

(1.5)

: Transmission ratio of vertically polarized light.

(1.6)

: Reflection ratio for parallel polarized light.

(1.7)
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: Transmission ratio of parallel polarized light.

n1: Medium 1

n2: Medium 2

(1.8)

Fig. 21.7:	  Reflection of a beam at surface boundaries

The reflection respectively the translucence coefficients correspond to the squares of the respective ratios.

(1.9)

In einem Diagramm aufgetragen ergeben sich folgende Kurven:

Incidence angle in degree

R
efl
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n 
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 %

Fig. 21.8:	 Reflexion eines Laserstrahls in % in Abhängigkeit des Einfallswinkels

The curves in Fig. 21.8 on page 125 were calculated for a wavelength of 1 064 nm. The refractive index n 
of quartz glass is wavelength-dependent. It varies from 1.4498 to 1.4766 in the wavelength range of 350 to 
1 064 nm.

It can be clearly seen that the reflection characteristics depend on polarization. Thisalso applies to an angle 
of incidence of 45°, the angle of incidence at which the beam passes in the MicroSpotMonitor MSM. 

For this reason, the prisms are integrated in the MicroSpotMonitor MSM in such a way that the beam is 
diverted in all three spatial directions (see Fig. 21.6 on page 124). This ensures that always two of the three 
incidence planes of the prisms are perpendicular to each other and compensate the polarization effects.
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Nevertheless, the attenuation of the prisms remains a function of the wavelength and polarization of the laser 
beam.

In the optimal case for reflection,
•	 the laser beam is attenuated by a factor of 1,7 · 10-4 (λ = 350 nm;  polarized),
•	 in the worst case by the factor of 6 · 10-5  (λ = 1064 nm; || polarized).
For all other wavelengths (between 350 nm and 1 064 nm) and polarizations, the values interjacent. 

However, this only affects the measurements if the polarization changes over the beam profile. In this case, 
an additional prism can be mounted above the measuring objective. The radiation transmitted by the prisms 
is guided via mirrors to the absorber resp. to a trigger diode. 

21.4.2	 Fixed filter and filter wheel

For further attenuation of the beam, an arbitrary fixed OD filter (option) can be inserted into the beam path 
(see chapter 21.1 on page 117). Behind the retractable OD filter is a filter wheel (option). The filter wheel 
has 6 positions. It can be operated during the measurement via software control. The filter wheel is equipped 
with five filters with an optical density between 1 and 5. The 6th position remains empty in order to allow the 
laser beam to pass unfiltered.

Neutral gas seal filters have approximately the same penetrability in a large wavelength range. The degree of 
weakening can be varied with the type of glass and the thickness of the filter.
However, the filters are only capable of handling 100 mW/cm², that‘s why they are not suitable to substitute 
for prisms.
The maximum average power which the MicroSpotMonitor MSM can handle is 250 watts (500 W version 
with water cooling only). Be sure to use the aperture of the measuring objective when operating in this power 
range.

The formula for converting the optical density into the transmission coefficient in % is:

(1.10)

The Filter wheel can be selected to weaken the laser beam by a factor of 10 to 105. Taking both filter levels 
together results in a dynamic range of 200 dB.
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Fig. 21.9:	 Typical transmission curve of a neutral glass filter
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21.4.3	 Beam path extension (BPE)

The beam path extension allows the user to adjust the overall magnification of the system.

Beam path extension

Fig. 21.10:	 Beam path extension of the MicroSpotMonitor MSM

The beam path extension consists of four mirrors. Using the levers to adjust the magnification (see Fig. 5.1 
on page 13), it can be inserted in the beam path directly behind the filter wheel.

According to equation (1.1) for the measuring objective, this results in an enlargement of the overall image. 
The factor by which the magnification changes depends on the measuring objective and is approximately 
1.5.

When a beam part extension is used, it is important that the object distance be changed as well. The z-axis 
position of the MicroSpotMonitor MSM needs to be adjusted after activating or deactivating the beam path 
extension.

21.4.4	 Alignment objective (JO)

The beam search is simplified using the alignment objective. The alignment objective is another lens that is 
inserted in the image side beam path just like the beam path extension. 

Depending on the wavelength and the measuring objective used, it results in a reduction factor of 2 to 3. 
As the name implies, the adjustment lens is particularly suitable for adjusting the MicroSpotMonitor MSM 
because the reduction reduces the required positioning accuracy of the MicroSpotMonitor MSM.

The reduced imaging of the measurement plane can also be seen as an enlargement of the active area of 
the camera chip. The sensor area of the CCD sensor is 4.76 mm x 5.58 mm. Using a 10x measuring objec-
tive means that in the standard case the MicroSpotMonitor MSM has to be positioned to approx. 0.5 mm 
in the x- and y-direction, for example in CCD mode. With the help of the adjustment lens, this range can be 
extended to 1.5 mm.

The adjustment lens can be validated at wavelengths of 1064 nm and 532 nm. At the wavelength 
of 355 nm, it can only be used for alignment.
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21.4.5	 Absorber

More than 99.8 % of the transmitted beam power is redirected by the first two prisms through a mirror sys-
tem to an absorber. 

The absorber is a channel in which the beam is completely absorbed by multiple reflections. There are sev-
eral variants available, the air-cooled absorber (up to 200 watts of average power), the water-cooled 500 W 
version and the water-cooled versions of the HighPower MicroSpotMonitor (HP-MSM) and HighPower 
MicroSpotMonitor HighBrillance (HP-MSM-HB).

21.4.6	 Trigger diode

With the aid of a sensor, the transmitted beam of the third prism is used as a triggering signal. The threshold 
at which the sensor sends a triggering signal can be set by the user or automatically. This signal can be used 
by the software to control delay and exposure time as well as better measure pulsated laser beams.

21.4.7	 Charge-coupled device sensor (CCD sensor)

There are many different variants of CCD sensors. They differ in structure as well as read routines.

•	 Full Frame
•	 Frame Transfer (FT)
•	 Interline Transfer (IT)
•	 Frame Interline Transfer (FIT)

The variant used in the MicrosSpotMonitor MSM, Interline Transfer, is widespread in industry and offers the 
ability to control exposure time.
The CCD sensor used has a pixel pitch of 4.6 μm, at 1 024 × 1 360 photoactive pixels. The dynamic range 
of 55 dB is extended to more than 130 dB with the help of exposure time control. The exposure time can be 
set between 12 μs and 181 ms.

Structure of the CCD sensor

Die Fig. 21.11 on page 128 shows the schematic structure of the CCD sensor.
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Fig. 21.11:	 Structure of an interline transfer CCD sensor

  Expose individual pixels: 12 μs – 181 ms
  Transfer to shift registers: 10 μs
  Transfer to output register: 10 μs (12 ms for 1 200 lines)
  Read the output register: 100 μs – 120 ms per line
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The light-sensitive pixels are surrounded by vertical registers. During a photo transfer command, data from 
the active pixels is transferred to the shift registers. So that pixel offset is not too great, the vertical registers 
are not actually to the side, but behind the light sensitive pixels. They are called shift registers because they 
are not light-sensitive. The vertical registers transfer data to the horizontal register. Data is trasferred line by 
line.
Around the photoactive pixel array are additional lines and rows of non light sensitive cells. These cells store 
data for the CCD’s internal control and are read along with the image information from the light sensitive 
pixels.

These processes are controlled by counters, whose values are assigned to specific actions. The most impor-
tant counter, the line counter, controls the actual output. With every increment of this counter, a new pixel line 
is transferred to the horizontal register. In addition to timing output of image data to the output register, this 
counter also initiates all other important commands such as sub pulse or photo transfer. For example, each 
increment causes a sub pulse to be sent.

The line counter is controlled by the ouput counter. Using the line and output counters, it’s possible to get 
the precise location of every individual pixel at any given time. When the output counter has reached its 
maximum value, all pixels are read, the counter resets to zero, the line counter increments, the next row is 
transferred to the ouput register and then read.

Other counters include the delay counter and exposure counter. These control the delay and exposure times 
respectively.

Fig. 21.11 on page 128 shows the sequence of steps as well as approximate timing. Reading the output 
register can take up to ten times as long as the other steps. After exposure, it takes about 132 ms to read 
all pixels in the sensor. The output register requires 120 ms of that time. In order to speed up output, the 
MicroSpotMonitor MSM can limit the amount of data to be transferred.

Since the MicroSpotMonitor MSM measures laser beams with a diameter of a few μm, a sensor size of 
4.76 mm x 5.58 mm is sufficiently large. Even if the laser beam is expanded with the help of the measuring 
objective, only a small part fo the chip is illuminated. This area is limited with a measuring window which is 
regulated by the user through the software. For example, if the measuring window extends from line 800 to 
1120 with a resolution of 32 x 32, then only every 10th line starting from line 800 is necessary to calculate 
the light distribution. Lines 0 through 799 and those above 1 120 are processed in fast scan mode. Only the 
first 50 values are read from the output register before the counter is incremented and the next line trans-
ferred to the output register.

In order to clear the output register, line 799 has to be completely read. Line 800 must also be completely 
read and the values processed. The fast scan mode is approximately 25 times faster than the normal output 
routine.

Within the measuring window, lines are read using the scan interleave mode. Since every 10th line is required 
within the measuring window, the 1st through 8th lines are only partially read while the 9th and 10th are fully 
read.

The total measuring time using this method is reduced by factor of 7.
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Smear effect

Fig. 21.12:	 Example of smear effect

During intense illuminations, it’s possible to experience smear effect. Visualization of this effect is seen 
through a signal bar that starts from a bright location of the image and extends to the edge. This effect oc-
curs because loads are generated in the shift registers by high intensity light. When the chip is read, all load 
packets above the bright beam are raised by a specific offset value.

A black measurement is done with the MicroSpotMonitor MSM before each measurement (even during trig-
gered operation) to compensate for this effect. During a black measurement, registers are cleared, exposure 
time cycles, and the CCD is read without having made an image transfer. The black measurement produces 
data that corresponds to the smear effect. The black measurement data is removed from the normal image.

Dark current

During long exposures, a second effect can occur. Dark current occurs because power (thermal electrons) is 
generated in the light sensitive pixels. This effect is the same for each pixel, independent of exposure inten-
sity, and increases linearly with exposure time. Dark current produces image offsets during long exposure 
times. There are integrated routines in the software to compensate for this effect.

Output

The line counter guarantees that the CCD sensor is read line-by-line as long as no measurement was start-
ed. At the start of a measurement, the line counter is reset to zero. It is stopped when it reaches a certain 
value, that is a certain line (x0). The line counter triggers a command to clear the shift registers and pixel data. 
The delay period counter starts immediately after this. 

During this time, sub pulses are generated at specific intervals to ensure that the pixels are totally clear 
before actual exposure (illumination). The exposure counter starts after the delay period. The line counter is 
reactivated after the exposure time has passed.

The shift registers are first read without an image transfer. This black measurement data is processed and 
the line counter is reset to zero. This process is immediately repeated after the exposure time has passed 
and the image transferred.

Image information is stored in the shift registers and available for output.
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Trigger

One trigger mode is available to diagnose pulsated laser systems. The trigger signal comes from a photo 
diode below the fourth prism. The trigger threshold (signal strength at which a trigger signal is generated) can 
be set through a dialogue window in the software.

In trigger mode, a fixed delay and exposure time is set. Even during triggered operation, a black measure-
ment is taken. This measurement starts like a normal operation in line x0. The registers and sensor matrix are 
cleared.

If a trigger signal is received during clearing, the registers and pixels are cleared again. If no trigger signal is 
received, the sensor is ready for measurement. As soon as a trigger signal is received, the delay counter and 
then exposure counter is activated. During this time, sub pulses are repeatedly generated to prevent illumi-
nation before the actual exposure. Then, the shift registers are read without an image transfer. This process 
immediately repeats unless an image transfer command is received.
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21.5	 Measuring pulsed irradiation 

The CCD sensor of the MicroSpotMonitor MSM has a dynamic of 55 dB. An integration time control has 
been implemented in order to expand this. The integration time can be freely chosen within the range of 
12 µs to 186 ms. 
If the Optm. (Optimize) function is activated in the Single or Caustic dialog window, then the LaserDiagnos-
ticsSoftware LDS will automatically – using a series of pre-measurements – set the integration time at which 
the output signal of a pixel in the array is too high. The optimal integration time will then be a little below that.

Fig. 21.13:	 CCD settings in the dialog window CCD Setting

The integration time control magnifies the dynamics of the CCD sensor from 55 dB to over 130 dB. Once the 
Optim. Function is deactivated, a set integration time can be specified in the CCD Setting dialog window in 
the MicroSpotMonitor MSM (see Fig. 21.13 on page 132).

Integration time control alone isn’t enough to be able to measure the full range of pulsed lasers. If, for ex-
ample, it involves a pulsed laser with a very low pulse frequency (< 5 Hz), the maximum integration time of 
186 ms will no longer be sufficient. This is why, in addition to the integration time control, a trigger option and 
delay time is also implemented.

In regards to triggering, there is an internal trigger and an external trigger. 
A photo diode behind a prism functions as the internal trigger. 
The user can determine the limit value of the trigger (0 ... 4 096). 
The trigger is preset to the value 2001 This setting works well for the majority of all applications.
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Trigger

Level  
0 ... 4096

Delay time

Sequential-control camera

Integration time

Fig. 21.14:	 Options for affecting the sequence control of the CCD sensor

Fig. 21.14 on page 133 Shows that the trigger, together with the adjustable delay and integration time, in-
terferes with the sequence control of the CCD sensor. The user can now define discrete time frames in which 
the LQM is allowed to measure. The external trigger is connected via a BNC socket meant for this purpose. 
Similarly, it also interferes with the sequence control, meaning that it can be handled in the same way as the 
internal trigger.

The delay time and trigger type (external or internal trigger) settings are made in the CCD Settings dialog 
window of the LaserDiagnosticsSoftware LDS.
When you enter a delay or integration time, you must always be sure to confirm these entries with the Up-
date button. 

There are the following time constants: 

Timeout:	  		  20 sec (Standard)
Minimum integration time: 	 12 µs
Maximum integration time: 	 186 ms
Minimum delay: 			  12 µs
Maximum delay: 		  186 ms

The long timeout time (20 sec.) also helps to measure lasers with a pulse that is manually triggered. If this is 
the case, a measurement must first be taken. The MicroSpotMonitor MSM will move to the desired position 
and run through a certain routine internally. Once the MicroSpotMonitor MSM is ready for a trigger, notifica-
tion of this will be displayed in the Free Communication dialog window. Right after the measurement is 
initiated, a communication flow will be visible. 

If this stops with the indication Waiting for Trigger, then the MicroSpotMonitor MSM is waiting for a trigger.
Every measurement of the MicroSpotMonitor MSM consists of a dark measurement and a measurement with 
photo transfer. This applies for triggered as well as untriggered operation. This means that each measure-
ment requires at least two trigger signals or two laser pulses.
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21.5.1	 Measuring configuration selection

There are various measuring options to differentiate between: 

•	 Measuring a single plane or a complete caustic
•	 Measuring a complete pulse or just a single section
•	 Measuring with a fixed integration time or with integration time control
•	 Measuring with triggered or untriggered operation
•	 Variations of optimal integration time caused by changing the attenuation

If you combine these measuring options with the pulse parameters:

•	 Pulse duration: fs – ms
•	 Pulse frequency: 1 Hz – 1 kHz

There are several options. The following merely describes a rough structure that is intended to help in choos-
ing measuring settings.

21.5.2	 Influence of the pulse parameters on the integration time control

The software-operated integration time control always assumes that there is a continual laser beam. 
This may cause quantization of the integration time for slow pulse lasers (< 500 Hz) or lasers with high pulse 
energy (integration time very short). Tab. 21.1 on page 134 And the diagram in Fig. 21.15 on page 135 
makes this clear.

Pulse frequency Number of pulses in

in Hz 186 ms 1 ms

1 0 0 - 1

5 1 0 - 1

10 2 0 - 1

50 9 0 - 1

100 19 0 - 1

200 37 0 - 1

500 93 0 - 1

1 000 186 1 - 2

2 000 372 2 - 3

5 000 930 5,00

10 000 1860 10,00

Tab. 21.1:	 Number of detected pulses in correlation with the integration time and pulse frequency
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Fig. 21.15:	 Percentage of change in the detected energy when exactly one pulse is left out, in correlation with the pulse 
frequency

Tab. 21.1 on page 134 Shows the number of detected pulses during the maximum integration time (186 
ms) and during an integration time of 1 ms for various pulse frequencies. 
Quantization with low pulse frequencies is clearly illustrated in the column for the 186 ms integration time. 
While 1 860 pulses are detected at a pulse frequency of 10 kHz, at 10 Hz there is only one or no more than 
two.

If the signal level is too high during a measurement at 10 Hz pulse frequency and the software tries to ad-
just the integration time, there are only three possible results. The energy application for a measurement 
remains the same, it decreases by 50 %, or it drops to zero. These increments are less significant at a pulse 
frequency of 10 kHz. This correlation is shown in general terms in Fig. 21.15 on page 135. It is important 
to recognize that, starting from a pulse frequency of 500 Hz, the minimum jump when the integration time is 
shortened amounts to 1 %. 

Small pulse frequencies aren’t the only thing that will cause quantization though. If the pulse energy is very 
high and it isn’t possible to further increase the attenuation, the integration times will be smaller. In Tab. 21.1 
on page 134, an integration time of 1 ms is added to the maximum integration time. In this case, a pulse 
frequency of 500 Hz is not sufficient in order to pretty much continuously control the energy application for 
each measurement through integration time control.
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A total of four states can always be differentiated on the way from low to high pulse frequencies or from short 
to long integration times. This is demonstrated by the following example for measuring pulsed irradiation dur-
ing untriggered operation.

t in μs∆t in μs

I in W/cm²

Fig. 21.16:	 Measuring with different integration times

	 12 – 200 µs: 	 Sporadic measuring of pulses
	 200 – 400 µs: 	 1 pulse
	 200 – 2 ms:  	 Quantization noise cause by a varied number of pulses
	 2 – 200 ms: 	 Virtually continual integration time control 

Fig. 21.16 on page 136 shows pulsed irradiation. The pulse pauses amount to 200 µs. The required inte-
gration time of the sensor correlates directly with the intensity of the laser beam.

If it is smaller than the pulse pause as in Case 1, no more than one pulse will be in the measurement statisti-
cally speaking. The probability of there being one pulse during each measurement of integration time control 
as well as during the actual measurement is slim. 

If the optimal integration time falls exactly between the simple and double duration of the pulse pause, there 
will always be just one pulse in each measurement (Case 1). This is the perfect state for measuring on one 
plane. The caustic can also be measured with this setup, since the dynamics of the CCD sensors is 55 dB 
for a single pulse, with the intensity only varying by a factor of 5 in the relevant caustic range. Here it is im-
portant to make sure that the signal saturation for the measurement in the beam waist is as high as possible. 
Only then is it possible to ensure that there is a sufficient S/N ratio when measuring a plane far outside of the 
focus.

Case 3 describes a situation where the integration time falls between the simple duration and the duration 
times ten of the pulse pause. Within this range, every pulse is more or less noticeable as a clear signal jump 
during the integration time. Integration time control is only possible with quantization. The measuring results 
often have a bad S/N ratio or the signal level is too high.
If the integration time increases even more, the signal jumps become flatter. Integration time control pretty 
much operates continuously (Case 4). The laser being measured can now be measured as a cw laser. 

The neutral-density filters, which can be inserted into the optical path, make it possible to always work within 
the desired range 1 - 4.

Furthermore, as was mentioned in the initial consideration, the MicroSpotMonitor MSM is equipped with 
quite a few options for triggering. Combined with integration time control and delay time control, it is possible 
to take good measurements even in Case 1.
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These four cases can generally be sorted into two groups. Case 1 and 2 must be measured in the triggered 
measuring mode. Case 4, however, is best measured in untriggered measuring mode cw. Case 3 should be 
avoided altogether by choosing a suitable filter. 
The below diagram in Fig. 21.17 on page 137 should help with case classification for the laser beams to be 
measured.

Measuring Mode - cw

Pulse frequency

Pulse duration1 μs
1 Hz

1 MHz

1 kHz

10 Hz

10 kHz

100 Hz

100 kHz

1 s10 μs 10 s100 μs 100 s

Measuring Mode - Triggered

Measuring Mode - Quasi cw

Fig. 21.17:	 Choosing the measuring mode through laser parameters

If the laser is in the blue range, it is best to choose measuring mode cw. It is, however, important to remem-
ber that the closer you get to the limit during triggered operation, the greater the integration time will be in 
order to achieve the virtual cw case. As a rule of thumb, the integration time within the focal point should 
amount roughly to the time for 35 pulses. If the laser being measured falls below the limit frequency of ap-
prox. 500 Hz, you should switch to triggered measuring mode.

While it is almost always possible to measure with the integration time control (optim. function) in the cw or 
virtual cw measuring mode, it only makes sense to use it for very long pulse durations (>1 ms) in triggered 
measuring mode. With the help of the attenuation filter, the integration time is thus set so that it only amounts 
to a fraction of the pulse duration. The trigger will then merely specify to the device the starting time for the 
measurement. The integration time may increase or decrease during the course of the caustic measurement 
without leaving the pulse path (see Fig. 21.18 on page 137 or Example 2). 

IntegrationszeitIntegration time (e. g. 100 μs) 

P Laser

t
min Delay (12 μs)

tp – 1 ms

Fig. 21.18:	 Measuring parameters for pulsed laser systems with pulse duration greater than 1 ms

In all situations, it is advisable to specify a fixed integration time in order to, through the skilled selection of 
the filter as well as the delay and integration times, make sure that a fixed number of pulses is always mea-
sured (see Example 1).
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21.5.3	 Examples for triggered measuring mode

Example 1: 	 Pulse duration 50 ns
		  Pulse frequency 1 kHz

MicroSpotMonitor MSM Settings:
Delay:	  		  950 µs
Integration duration: 	 0.1 ms
Trigger channel: 		 External trigger

Depending on how precisely you are able to set off the trigger, you can also extend or shorten the integration 
time.

Measure:	
Initiate a measurement. You now have 20 sec. to set off a trigger. 
As a result of the delay value of 0.95 ms and the fixed integration time of
100 µs, the MicroSpotMonitor MSM detects the second laser pulse after setting off the trigger. 

Example 2: 	 Pulse duration 1 ms

MicroSpotMonitor MSM Settings: 
Delay:			   12 µs
Integration duration: 	 1 ms
Trigger channel:		  Internal trigger

Measure:
Initiate a measurement. You now have 20 sec. to set off a laser pulse.
The MicroSpotMonitor MSM measures 12 µs after the trigger is set off.
In this example, the first 12 µs of the laser pulse are not measured: 

Example 3: 	 Measuring exactly one pulse
		  Trigger mode: Triggered operation

In the CCD Settings dialog window, there is a selection menu called CCD Operating Modes. There you can 
choose between background, raw data, and measurement data.

When measuring in raw data mode, the CCD is read out quite normally. A second, dark measurement, is not 
performed though. Depending on the application case, wavelength, and integration time, there may be obvi-
ous errors in the background. 

It makes sense to measure in this mode when exactly one pulse will be triggered. Since there won’t be a 
second, dark, measurement, this single pulse is enough. Here the attenuation should be chosen so that the 
integration time is longer than the pulse duration. This makes it possible to avoid most background effects. If 
the integration time is too long though, more dark electrons will be generated. 

If you would like to record the entire pulse, it must be triggered externally. In this case, the minimum delay 
between the trigger and start of the measurement should be 12 µs.
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21.5.4	 Summary

If the laser is pulsing at a high frequency (> 500 Hz) or if the pulses last a long time (> 1ms), it is best to mea-
sure with the Optim. option. This makes it possible to vary or optimize the integration time during a caustic 
measurement. 
For the long pulse duration, choose the attenuation so that the integration time is smaller than the pulse 
duration even outside of the focal point.
When the pulse frequency is very high, however, the attenuation must be chosen so that enough laser pulses 
are integrated during the measuring cycle. If too few pulses come during an integration time, the number of 
photoelectrons will change too much with each pulse. The regulating routines of the LaserDiagnosticsSoft-
ware LDS will then lead to measurements with signal levels that are statistically too high.

It is important to make sure that the integration time is never smaller than the pulse pauses. If this is the 
case, it will no longer be possible to perform an untriggered measurement properly with the MicroSpotMoni-
tor MSM.

So it sometimes makes sense to set the attenuation so that exactly one pulse is enough to expose the sen-
sor at the focal point. You can then measure a caustic with a fixed delay and an integration time set when the 
focus was measured. The dynamic of the CCD sensor (55 dB) is sufficient to measure the entire caustic with 
an acceptable S/N ratio.
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22	 Basis of laser beam diagnosis

22.1	 Laser beam parameter

z-axis
z-axis

Raw beam diameter dσ

Focal length fDivergence angle θ

θ

Focus diameter dσF

dσF

zR

Fig. 22.1:	 Sketch for the definition of beam parameters
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22.1.1	 Rotationally symmetric beams

According to ISO 11145 as well as ISO 11146 three beam parameters are necessary for the characterization 
of a rotationally symmetric beam:

•	 	the z-position of the beam waist (focus) z0

•	 	the diameter of the beam waist dσF

•	 	the far field divergence angle Θ

By means of these three values it is possible to determine the beam diameter at every spot along the propa-
gation direction. The following restriction is applicable: The divergence angle has to be smaller than 0.8 rad 
and the focus diameter and the divergence angle were determined with the 2. moment method.

(1.1)

Furthermore, the beam propagation is described by means of the so called beam propagation ratio K.

(1.2)

with:
K	 = beam propagation ratio
M²	 = beam propagation factor
λ	 = wave length in a medium with the refractive index n
Θσ	 = divergence angle
dσ0	 = beam waist diameter

The derived beam parameter product, is a constant size as long as image defect free and aperture free com-
ponents are used.

(1.3)

An important beam parameter is the Rayleigh length:

The rayleigh length is the distance towards the propagation in which the laser beam has increased by . It 
can be calculated by means of the following formula:

(1.4)
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22.1.2	 Non rotationally symmetric beams

In order to describe non rotationally symmetric beams, the following parameters are required:

•	 the z-position of the beam waist (focus) zx and zy

•	 the diameter of the beam waist dσ0x and dσ0y

•	 the far field divergence angle Θσx and Θσy

•	 the angle ϕ between the x´-axis of the measuring system and the x-axis of the beam (the x-axis of the 
beam is the one closest to the x-axis of the measuring system.)

Beam coordinate system (x, y)

y-axis

x-axis

x-axis

y-
ax

is

Device coordinate system (x, y)

Fig. 22.2:	 Beam parameter of the not rotationally symmetric beam

All beams which can be characterized by two axes which are perpendicular to each other can be described 
by means of the above mentioned parameters.

Further beam parameter such as the K-figure or the beam propagation factor are calculated directionally by 
means of as the same equations as the rotationally symmetric beams. This always results in two parameters 
such as Kx and Ky. 
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22.2	 Calculation of beam data

For the calculation of the beam data not only the algorithms for the 2. moment method are implemented as 
demanded by the ISO standard 11145 but also the 86 % method which is widely-spread within the industry.
For the Gaussian TEM00-mode both methods offer similar results whereas in case of the majority of other 
laser beams the 2. moment method calculates bigger beam diameters than the 86 % method.
Laser radiation often is a mixture of different modes with different frequencies and coherent characteristics. 
All known measuring procedures only provide little information on the beam. Therefore the calculated beam 
parameters are always dependent on the measuring procedure. For the interpretation of the measuring re-
sults it is important to be aware of this fact.

The calculation of the beam radius requires the following to preparatory steps:

1.	 	Measurement of the power density distribution
2.	 	Determination of the zero level
3.	 	Determination of the beam position

22.2.1	 Determination of the zero level

The zero level can – for instance – be determined by means of a histogram by applying the frequency of the 
measured power density values (please see Fig. 22.3 on page 143). 

Fr
eq

ue
nc

y 
(a

u)

Zero level of the signal

Relative intensity in counts0 4095

Fig. 22.3:	 Schematic histogram of the scanned measuring points

The histogram shows how frequently a certain power density was measured. The maximum of this curve 
indicates the power density of the zero level. The power density is deducted from all measured values of the 
power density distribution.

It is important to measure the zero level accurately because even the slightest error would lead to a drastic 
change as far as the volume is concerned. This in turn has a great impact on the measured beam radius.
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22.2.2	 Determination of the beam position

The beam position is determined by means of the 1. moment method. This means the moment of inertia of 
the power density distribution (E(x, y, z)) is determined.

(1.5)

As mentioned at the beginning of the chapter, there are two possibilities how to determine the beam radius 
after the determination of the beam position.

22.2.3	 Radius determination with the 2. moment method of the power density distribution

The calculation of the beam radius according to the 2. moment method of the power density distribution is 
effected as shown in equation (1.6).

(1.6)

Based on equation (1.6) the beam diameter is determined as follows:

(1.7)

This algorithm contains the product derived from the power density and the squared distance to the moment 
of inertia. It is only reliable when the zero level is determined correctly. The fill factor, the ratio of the beam 
diameter divided by the integration range/measuring window size is a further important quantity. It should 
always have a value between 0.35 and 0.7.
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22.2.4	 Radius determination with the method of the 86 % power inclusion 

The first step is the determination of the volume of the power density distribution. It is proportional to the total 
power. The addition of all power density values and their multiplication with the pixel dimensions result in the 
volume and therefore the total power. A reliable zero level subtraction is the fundamental basis.
Based on this total power, the focus lies on the range which includes the 86 % of the total beam power. This 
beam power must lie within the beam radius.
The integration typically starts with the values of the maximum power density. Then the integration range is 
enlarged until 86 % of the total power lie within the radius. As far as the integration is concerned, the number 
of pixels is counted. By means of this the 86 % range which means the beam diameter can be determined. 
For circular beams similar to the fundamental mode beams the procedure works well.

Percent of beam power

100 %

a)

c)

b)

d)

86 %

Cross sectional area

Fig. 22.4:	 Graphical presentation of the calculation of the 86% radius

a)	 Shows the power density distribution.
b)	 Shows the pixels which include 86 % of the power together.  
	 As a clarification the pixels with a low power are set to zero.
c)	 Shows a section at the “86 % power density inclusion”.  
	 The level lies at 14 % of the maximum power.
d)	 Shows the section through the distribution at 86 %.
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22.2.5	 Further radius definitions (option)

Not all measuring devices for the laser beam diagnosis come to the same measuring result when carry-
ing out similar measurements with the same laser beam. Apart from a different validation of the measuring 
devices the measuring procedures and the used evaluation algorithms have an influence on the determined 
beam dimension. 
Not all the processes used comply with the valid standards. However, they are the preferred choice for in-
stance in the scientific area. For practical reasons, for instance for the design of the orifices or for the correla-
tion with processing results, it can also be helpful to use alternative beam radius definitions. 

As an option, we offer an extension to the following alternative radius definitions:

1.	 Knife edge method according to ISO 11146-3
2.	 Slit method according to ISO 11146-3
3.	 Gaussfit method 
4.	 1/e² power density loss method
5.	 Power inclusion method with a freely definable 1st power value
6.	 Power inclusion method with a freely definable 2nd power value

2. Moments Power inclusion Knife edge method

Slit method Gaussfit method 1/e²-power density

Fig. 22.5:	 Schematic illustration of the beam radius definitions that are offered optionally for the PRIMES 
LaserDiagnosticsSoftware LDS



147 Revision 02/2019 EN

MicroSpotMonitor MSM

22.3	 Measurement errors

Regardless of the measuring principle, there are many sources of errors in determining beam radius.

•	 Determination of the zero level
•	 Finite size of the measurement window
•	 Resolution in x and y directions
•	 Intensity resolution

22.3.1	 Error in determining zero level

Calculation of the beam waist radius is very strongly dependent on changes in the zero level. It doesn’t mat-
ter if the 86% or 2. moment method is used.

V1 = 0.86 (V1 + V2)

V1

V1

V2

V2

Positive offset

b

∆r+ ∆r-
ro

Negative 
offset

= Fill factorr
b

Fig. 22.6:	 Gaussian Intensity Distribution, zero level lowered (left) and raised (right)

Fig. 22.6 on page 147 illustrates this. When the zero level is lowered (left side), the total volume between 
the measurement values and the zero level increases. Because of this increase, a larger beam radius is cal-
culated using the curve equation. Conversely, if the zero level is raised (right side), the volume decreases and 
the computed beam radius will be too small.

22.3.2	 Saturating the signal

High signal amplitudes are clipped by the limited dynamics of the system. If the high power densities are 
missing from the calculation of beam geometry, the algorithm always computes a beam that is too large. This 
can be compensated for by increasing attenuation.
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22.3.3	 Errors from incorrect measurement window size

The entire laser beam must be within the measurement window for correct normalization of the volume of the 
measured distribution. Since the intensity distribution, in principle, extends infinitely, a fraction of the beam 
power is always outside the measuring range.
In the following, the normalization of beam radius is proportional by half to the window size. This size is de-
fined as the Fill Factor (F).

(1.8)
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Fig. 22.7:	 Error During Beam Radius Calculation by Offset of the zero level Plane for Various Offset Values (Gaussian 
Intensity Distribution)

In Fig. 22.7 on page 148, the effect of a Fill Factor greater than 0.7 can clearly be seen. For Gaussian-like 
beams, the Fill Factor should be held between 0.4 and 0.6 to minimize errors. For Top-Hat distributions, the 
limit is around 0.9.
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